1

I need to upgrade php on working server from 7.2.14 to 7.2.19

yum list installed php* shows only 7.2.14-1.el7.remi exist within installed packages.

I can't use yum update neither yum upgrade since this will upgrade pages I need them within their current versions.

OS: Centos7

  • AFAIK remi will limit the PHP to the same 7.2.x version. It should never go to PHP7.3. Could you post the output of a yum update php*? – Edward Jul 2 '19 at 12:26
  • @Edward yum update php* is going to update php and its dependencies, which is the thing I don't want, I need just to update php alone to that version. – Eng7 Jul 2 '19 at 12:35
0

I highly doubt you can update ONLY php base package. The remaining (excluded) packages will still depend on an older version, e.g. for php-json:

» yum deplist php-json
package: php-json.x86_64 7.1.30-1.el7.remi
<...>
  dependency: php-common(x86-64) = 7.1.30-1.el7.remi
   provider: php-common.x86_64 7.1.30-1.el7.remi
<...>

^ you see the dependency on php-common?

If I tried this: yum update php --exclude=php-json I would get:

--> Processing Dependency: php-json(x86-64) = 7.1.30-1.el7.remi for package: php-common-7.1.30-1.el7.remi.x86_64
Error: Package: php-common-7.1.30-1.el7.remi.x86_64 (remi-php71)
           Requires: php-json(x86-64) = 7.1.30-1.el7.remi
           Installed: php-json-7.1.29-1.el7.remi.x86_64 (@remi-php71)
               php-json(x86-64) = 7.1.29-1.el7.remi
           Available: php-common-5.4.16-46.el7.x86_64 (base)
               php-json(x86-64)
           Available: php-pecl-jsonc-1.3.10-1.el7.remi.5.6.x86_64 (remi-php56)
               php-json(x86-64) = 1.3.10
           Available: php-pecl-jsonc-1.3.10-2.el7.remi.5.6.x86_64 (remi-php56)
               php-json(x86-64) = 1.3.10
           Removing: php-common-7.1.29-1.el7.remi.x86_64 (@remi-php71)
               Not found
           Updated By: php-common-7.1.30-1.el7.remi.x86_64 (remi-php71)
               Not found
           Available: php-common-5.6.40-8.el7.remi.x86_64 (remi-php56)
               Not found
           Available: php-common-5.6.40-9.el7.remi.x86_64 (remi-php56)
               Not found
Error: Package: php-json-7.1.29-1.el7.remi.x86_64 (@remi-php71)
           Requires: php-common(x86-64) = 7.1.29-1.el7.remi
           Removing: php-common-7.1.29-1.el7.remi.x86_64 (@remi-php71)
               php-common(x86-64) = 7.1.29-1.el7.remi
           Updated By: php-common-7.1.30-1.el7.remi.x86_64 (remi-php71)
               php-common(x86-64) = 7.1.30-1.el7.remi
           Available: php-common-5.4.16-46.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-46.el7
           Available: php-common-5.6.40-8.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-8.el7.remi
           Available: php-common-5.6.40-9.el7.remi.x86_64 (remi-php56)
               php-common(x86-64) = 5.6.40-9.el7.remi

going around in circles...

  • Can't I just build it from the source code? – Eng7 Jul 2 '19 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.