0

I have a directory on a ZFSoL 0.8.1 filesystem into which I cannot seem to mount anything, and I am quite puzzled ...

mypool/           => /mypool
mypool/fs1        => /mypool/fs1
mypool/fs2/fs2-1  => /mypool/fs2/fs2-1

All filesystems have mountpoints as default and inherited.

I also have a folder /mypool/folder. First, I tried to set it as a mountpoint for a filesystem from a different zfs pool, mypool2/fs1. This did not work. No error message, but eventually, the folder

  • does not contain the data from the filesystem (ls /mypool/folder
  • the filesystem is not mounted (zfs get mounted mypool2/fs1) and
  • the folder is not a mountpoint (mountpoint /mypool/folder)

Then I mounted mypool2/fs1 in the default location and tried to bind/mount the folder, to the same result. I can mount mypool2/fs1 a folder of a different name in the same location, and I CANNOT mount any other folder (ZFS or not) into /mypool/folder.

The mount command exit with status 0 and no error message, but the folder stays empty. Deleting and remaking it doesn't change anything.

/mypool/folder was, but currently is not in my fstab. It does not seem to be contained in any zfs property or any file in /etc. Nothing in dmesg. fuser and lsof do not return anything.

Anyone any idea, or some way forward to test?

migrated from superuser.com Jul 2 at 9:54

This question came from our site for computer enthusiasts and power users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.