0

I have Ubuntu 18.04.2 and I tried to install my printer Samsung M2070 following this list of commands found on this tutorial (that is unfortunately in Italian):

sudo apt update

sudo apt upgrade

sudo apt install suldr-keyring

Then I used this page in order to look for the name of my printer and find my driver version. Then i typedd in terminal:

sudo apt install suld-driver2-<version>

Now I can see my printer in the printers application and if I try to print a pdf file I have the possibility to choose my printer. However it is not printing and it is like the printer didn't receive the "print" signal.

Any suggestions?

  • Is your printer identification correct? I've been unable to locate information on a "Samsung M207O" printer. – David Yockey Jul 2 at 11:38
  • @DavidYockey sorry, it's M2070, I've edited the question! – ele Jul 2 at 11:46
  • Can you print the test page? Are you sure you chose the correct driver in the printer setup? – Fiximan Jul 2 at 12:29
  • @Fiximan no, the possibility to print the test page is not available – ele Jul 2 at 12:50
  • In terms of "unclickable" or in terms of "inexistent"? – Fiximan Jul 2 at 12:54
0

Rather than trying to deal with an unofficial repository such as SULDR, it might be best to install the driver from the official source and see if that works better.

The driver is available from https://support.hp.com/us-en/drivers/selfservice/samsung-xpress-sl-m2070-laser-multifunction-printer-series/16450377. (Note: HP purchased Samsung's printer business a couple years ago)

After uninstalling the SULDR stuff, download the driver from the link above, extract it, and then run the install.sh script found in the extracted directory. I don't know for sure, but logging out and back in or rebooting may be necessary after the install.

If you wish to continue attempting to install through SULDR, they have a forum that might help at https://www.bchemnet.com/suldr/forum/.

  • How can I unistall SULDR? (Sorry this is my third week with Ubuntu!) – ele Jul 2 at 12:49
  • No prob. It's just like installing except you'd do sudo apt remove ... instead. – David Yockey Jul 2 at 13:05
  • I did all the steps, but It still doesn't work. EDIT: I have removed and added again the printer and now it works! – ele Jul 2 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.