0

I'm trying to change display resolution using following these steps: https://gist.github.com/debloper/2793261. I'm using 7 inch HDMI USB powered display and this is commands that I used:

#

# gtf 800 480 60
  # 800x480 @ 60.00 Hz (GTF) hsync: 29.82 kHz; pclk: 29.58 MHz
  Modeline "800x480_60.00" 29.58 800 816 896 992  480 481 484 497 -HSync +Vsync

# xrandr --newmode "800x480_60.00" 29.58 800 816 896 992  480 481 484 497 -HSync +Vsync

# xrandr --addmode HDMI-1 "800x480_60.00"
# xrandr --output HDMI-1 --mode 800x480_60.00

Once that is done I find that display didn't match with selected resolution: enter image description here

As you can see writing xrandr -q, in current resolution is 800x800.

What am I doing wrong?

3
  • This comment is all conjectures. If you're displaying simultaneously on two outputs, one 800 width, the other 800 height, Screen (which is virtual) will take the largest of each. Maybe there's also a rotation to apply? – A.B Jul 2 '19 at 8:24
  • Nice comment, I'm only using HDMI-1, I'used LVDS-1 for other project and it displays 480x800 good. Maybe I can try to disable LVDS-1 or rotate it. – Oriol Herrera Escardó Jul 2 '19 at 8:32
  • Once you get it working, you should write an answer – A.B Jul 2 '19 at 8:34
1

The problem that I have with display was caused because LVDS-1 (that I'm not using) was configured to work in vertical and height resolution was bigger than 480, so virtual desktop can't be smaller.

I resolved it using next command:

xrandr --output LVDS-1 --off

Thanks to A.B for your contribution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.