0

1-sudo apt install nginx

2-sudo chown user /var/www/html

3-sudo geany /var/www/html/index.html (put hello world!)

4-/etc/nginx/sites-enabled/default change :

server { listen 81 default_server; listen [::]:81 default_server;

5-192.168.0.1 in OpenWRT based router (Zyxel EMG2926-Q10A at default settings form ISP)

Put port-forward to port 81

6-sudo systemctl restart nginx

7-test local-ip:port Work

8-check external ip online

9-test external-ip:port don't work

10-test external-ip:80 Rejected request from RFC1918 IP to public server address

11-scan port 81 online, see it's open with low ms latency

12- try dmz, still don't work, revert settings

  • not sure what you did ... you mentioned port 18 and port 80 ... you created index.html using sudo ... i think that may make the file owned by root ... did you try using a web browser at step 7 either using an external device or locally at localhost:81 – jsotola Jul 2 '19 at 4:15
  • Was a typo for 18, it was 81 ... which chmod or chown to set ? I did test on the same device so localhost:81 and with internal ip instead of localhost. you created index.html using sudo ... i think that may make the file owned by root ... did you try using a web browser at step 7 either using an external device or locally at localhost:81 – zillion Jul 3 '19 at 1:33
  • Also trying zerotier one at the moment, it's a mess ... – zillion Jul 3 '19 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.