4

With Debian 9.9 and GNOME 3.22, I'm trying to load the OS without boot menu. I've installed plymouth to show a graphical loading and set this options in grub:

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

But for a split second, I still see some kind of grub menu. This time with no options.

What I see is an image located here /usr/share/images/desktop-base/desktop-grub.png, and a text that says

loading linux 4.9.0-9-amd64...
loading initial memory image...

Then plymouth theme is shown and normal boot happens.

Is it possible to hide this? I would like to just see the theme

1

A suggested solution from https://askubuntu.com/questions/248/how-can-i-show-or-hide-boot-messages-when-ubuntu-starts...

...for just a (usually) black screen, try:

GRUB_CMDLINE_LINUX_DEFAULT=quiet   #Don't show Ubuntu bootup text
GRUB_CMDLINE_LINUX="console=tty12" #Don't show kernel text
7
  • 1
    if I remove splash then plymouth is not showing....If I do the tty12 thing, then computer halts when trying to show plymouth Jul 3 '19 at 16:58
  • now I can't boot Jul 3 '19 at 17:00
  • i'ts like plymouth is broken now and can't boot. how can I fix this? I need to edit grub Jul 3 '19 at 17:04
  • What is displayed? Is it just displaying a blank screen? Jul 3 '19 at 17:19
  • 1
    Booting from a live distro and editing /etc/default/grub from there may get around the problem, as suggested at ubuntuforums.org/showthread.php?t=1650021. (I get that your's is Debian, but Ubuntu info seems to be what's turning up.) Jul 3 '19 at 17:37
1

Try setting

GRUB_TERMINAL=console, once it is showing this png file!

0

Try deleting these lines in /etc/grub/grub.cfg

echo    'Loading Linux XXX-generic ...'
echo    'Loading initial ramdisk ...'

Worked for me

1
  • Didn't you mean: /boot/grub/grub.cfg? On Debian 10.9 that file is generated after invoking update-grub, and shouldn't be edited manually. Instead, you can change the quiet_boot variable in /etc/grub.d/10_linux in order to remove those messages from the resulting config.
    – rel
    Jun 11 at 0:10
0

A solution that finally worked for me under Debian 10.9 (Buster):

$ uname -a
Linux hmi 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux

$ cat /etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash gfxpayload=text loglevel=3 rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0"
GRUB_CMDLINE_LINUX="console=ttyS0"

$ sed -i 's/^quiet_boot="0"/quiet_boot="1"/g' /etc/grub.d/10_linux

$ update-grub
$ reboot

GRUB should now be silent and there should be no visible boot messages on the screen (note: some variables set in GRUB_CMDLINE_LINUX_DEFAULT are probably not necessary). - This gist helped to solve the issue.

This solution is not related to plymouth, but might still add some valuable information to solve the original issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.