1

I've added my arabic layout in /usr/share/m17n and I've no problem with Alphanumeric and Keypad mapping, it works fine. Here's how it looks like:

(input-method ar phonetic)
(map
 (arabic
 ("1" "١")
 ("2" "٢")
    .
    .
    .
 ((KP_0) "٠") 
    .
    .
    .
 ;;((G-1) "١")
 ;;((G-2) "٢")
)

(state(init(arabic)))

If I uncomment last two lines of map to enable AltGr options, instead of arabic I get english! I don't have AltGr key BUT I used Alt-Right or Ctrl+Alt on Windows 10 for that.

0

I just had to move AltGr part in between Alphanumeric and Keypad to make it work in this way:

(input-method ar phonetic)
(map
 (arabic
 ("1" "١")
 ("2" "٢")
    .
    .
    .

 ((G-1) "۩")
 ((G-2) "ﷱ")
    .
    .
    .

 ((KP_0) "٠") 
    .
    .
    .
)

(state(init(arabic)))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy