1

I'm trying to change my boot scheme from BIOS to UEFI on my laptop. As part of that, I'm trying to install Linux Mint on the SSD - previously used OS was LM on the SSD with legacy bootloader mode. But I can't get the computer to boot. I've tried reinstalling a few times. I'm letting the installer use its default configuration and erase the drive. I've also tried turning LVM on and off, but haven't touched any other settings. For whatever reason, I'm not getting a drive that my UEFI will recognize as a boot option.

In this album I have pics of the SSD with the freshly-completed Linux install, compared to a new Linux install on my desktop with the same installation settings. My desktop is working fine and happily booting to the new install. My best guess is that the issue lies with the fat32 partition not having the /boot/efi mount point. Does that explain the issue? If so, how can I resolve it?

0

... not getting a drive that my UEFI will recognize as a boot option.

Uefi works a bit the other way round: you have to tell it actively which "EFI application" from the ESP you want to see in your boot list. See efibootmgr to do this from Linux. Or bcfg from Uefi shell.

I use the Uefi shell for booting. Activate it as boot option like "USB Devices". First you get a shell> prompt, then type fs0: to get on the ESP. Then just type "vmlinuz" or whatever your kernel is called, add initrd=foo and root=/dev/bar. You have tab completion and colored filenames and you can actually collect kernels and initrds in folders on your ESP, from where you can start them directly. To reuse a KCL (kernel command line) you can echo it to a .nsh script.

I was not able to put a kernel in the uefi boot menu. It needs a full EFI app for that, I think, and the kernel only has EFI-stub.

Installing grub on uefi looks like it just copies that GRUB.EFI to ESP. Afterwards you use efibootmgr or bcfg, besides configuration of grub.

I almost broke my head about how to mount that ESP (/boot/EFI) following grub docs. I am here know exactly because I found the hint "you don't need a boot loader if you have uefi". It is true!

(Only for unattended boot without the 5 sec killable countdown in uefi shell I might still install grub one day)


added: Here you see the confusion:

Why do most distributions chain UEFI and grub?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.