3

I am running manjaro. I first noticed this problem when I was trying to install games on my second storage drive from Steam. I would try to install a game, and it would work for a bit, but then steam would lock up. Additionally, when I try to manually transfer music files or whatever in the terminal, the process would sometimes work, but sometimes lock up and list the status "D" in htop. Once the processes locks up, I can't navigate the mountpoint of the drive at all.

I re-partitioned the drive (ext4) and tried to reseat the SATA cable and neither of those things worked. I ran the long SMART drive test or whatever it is called and it showed no errors. As I am writing this, I have noticed that the process /usr/lib/udisks2/udisksd is also in the "D" state.

What the heck can I do?

1 Answer 1

0

There is nothing wrong with the state "D" as such, it just means that the process is waiting for a disk operation to complete. Most of the time, it will be a read operation, but it can also be a synchronous write operation.

The problem is if the process stays in that state. This is difficult to distinguish from the process leaving that stat when the I/O is complete and entering the state again for the next operation. In particular, a process can't be killed while it is in state "D".

If there is a problem with a disk, you should see error messages in the output of dmesg.

6
  • I know D isnt bad by itself, its just that the whole system starts freezing up when I do a basic file transfer, but only after a while. Again, sometimes it works just fine. But dear lord, this is the longest output from a command I've ever seen. what am I looking for here? towards the end theres a few outputs that are like INFO: task kworker/u32:10:263 blocked for more than 120 seconds. all in red. Commented Jun 30, 2019 at 18:11
  • Here are all level 3 (the highest level output i got) ouputs: pastebin.com/BkQhs8MA Commented Jun 30, 2019 at 18:19
  • I had expected something about disk errors, but blocked for 120 seconds also doesn't sound good. Unfortunately, I don't know what causes that.
    – RalfFriedl
    Commented Jun 30, 2019 at 18:44
  • hm dang, thanks for the help Commented Jun 30, 2019 at 18:52
  • What happens to RAM usage leading up to this point? Commented May 19, 2020 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .