2

In Debian I have set up multiple users. The OS was installed in English. Next I ran sudo dpkg-reconfigure locale and selected multiple other languages (such as German, Spanish, and French) and installed them. I then created the new users all as standard users with no password. I logged in as one user "spanish" and edited their ~/.bashrc with the following:

export LANG=es_MX.utf8
export LANGUAGE=es_MX:es

I then logged out and logged back in. I checked in the console with

echo $LANG

which returned

es_MX.utf8

however, nothing on the system seems to have changed. The menu, all the applications, console, etc - everything is still in English.

I had hoped to be able to have different languages set for each user of the system. Am I doing this correctly or am I completely misunderstanding what "locale" is used for? If so, is it possible to have different language environments for different users in Debian 9 (stretch)? I'm using the Cinnamon desktop, if that makes a difference.

Also, would I need to install new, language-specific versions of Firefox and LibreOffice or are there language packs I could install?

EDIT: According to certain older documentations, the Language Module was removed from the Cinnamon Control Panel in versions 2.2 and later. (https://wiki.archlinux.org/index.php/Cinnamon#Manage_languages_used_in_Cinnamon) The only way to control it is apparently with a Mint-specific package called mintlocale, which, from what I can tell, doesn't have a Debian version. I was hoping there was a command-line or config-file way to accomplish the same thing, but I'm also willing to change distros to one that supports multiple languages if Debian won't work.

2

Changing users’ language in .bashrc only influences their shells, as you’ll see in a terminal session. To change their desktop environment’s language, you need to configure the desktop environment for each user. In some cases, that can be done from the login screen (see below). In other cases, language configuration is done in the desktop preferences.

Using the default desktop manager used with Cinnamon in Debian, there’s a drop-down language menu in the top-right-hand corner which should show the languages available on your system:

Language menu

There are language packages for Firefox and LibreOffice; look for packages with names starting with firefox-esr-l10n for Firefox, and libreoffice-l10n for LibreOffice.

  • 1
    Thanks for clarifying. I definitely want to change the desktop environment, not the shell (although terminal messages were also remaining in English). I tried selecting the language from the login screen dropdown but it had no apparent effect. There is no language settings option in the Settings screen in Debian 9 (stretch). Should I have used a different distro? If so is there one you can suggest? – lchras Jun 29 at 16:15
  • See my update. When you change the language on the login screen, you should see the login prompts change, and the chosen language should be applied to the desktop after login. – Stephen Kitt Jul 1 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.