2

Installed Debian yesterday and have had a pleasant experience except for my inability to get the Wired Connection working. I have a Wireless connection that connects and allows me to access Internet. The Wired connection activates, but does not have any Internet. I installed network-manager in hopes that it would do something.

ip a (when I am connected to both wireless and wired)

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 54:a0:50:88:02:67 brd ff:ff:ff:ff:ff:ff
    inet6 2601:410:4200:1490:3db7:b480:c149:bae3/64 scope global temporary dynamic 
       valid_lft 212562sec preferred_lft 85850sec
    inet6 2601:410:4200:1490:56a0:50ff:fe88:267/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 212562sec preferred_lft 212562sec
    inet6 fe80::56a0:50ff:fe88:267/64 scope link 
       valid_lft forever preferred_lft forever
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether dc:85:de:cb:f4:13 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.19/24 brd 192.168.0.255 scope global dynamic wlp3s0
       valid_lft 85510sec preferred_lft 85510sec
    inet6 2601:410:4200:1490:ae2d:d92b:d52e:bc36/64 scope global noprefixroute dynamic 
       valid_lft 212562sec preferred_lft 212562sec
    inet6 fe80::750d:dee3:cc5c:1169/64 scope link 
       valid_lft forever preferred_lft forever

Noticed that the eno1 is missing an IPv4 address.

Also tried tweaking files in

/etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

cat /etc/network/interfaces.d/* auto lo iface lo inet loopback

auto eth0
iface eth0 inet dhcp

One thing that I noticed so far is that my Ethernet is called eth0 in interfaces.d, while it's called eno1 from ip a. I tried to update the etho0 to eno1 and then restart the service, but was not successful. From my understanding of network-manager, the interfaces file should be ignored now?

cat /etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

Any help would be appreciated!

  • 1
    did you try changing eth0 to eno1? this may be the main issue, as it seems the system interface name is different than the one you try to set. – Bart Jun 28 at 13:56
  • 2
    @Bart , when I did that I got a new connection called Ifupdown (eno1), which activates but still fails to connect to Internet :( – Untitled123 Jun 28 at 16:12
  • 1
    During troubleshoot, you should temporarily disable the wireless interface to avoid any possible interaction. You can run a manual dhcp command. Assuming you have isc-dhcp-client, you should run dhclient -v eno1 and observe the results. You're supposed to see DHCPDISCOVER then DHCPOFFER then DHCPREQUEST then DHCPACK . Anyway you should add the results on your question. – A.B Jun 29 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.