0

I have set up a DHCPD service on a Linux server, which shall provide fixed public IP addresses for cable modem devices based on MAC addresses.

Here is the configuration file of the DHCPD. The server's IP address is 212.200.200.34 (it has only one interface) and the CMTS has the IP address 172.30.30.2. The CMTS and the DHCP servers are in the same VLAN 2000.

ddns-update-style none;
option domain-name-servers 8.8.8.8, 8.8.4.4;
default-lease-time 23200;
max-lease-time 86400;
lease-file-name "/var/db/dhcpd.leases";
authoritative;
log-facility local7;

shared-network CMTS-PUBLIC-IPS {

subnet 212.200.200.32 netmask 255.255.255.224 {
 option dhcp-server-identifier 212.200.200.34;
 server-identifier 212.200.200.34;
 option routers 212.200.200.33;
 option subnet-mask 255.255.255.224;
 option time-servers 212.200.200.34;
 range 212.200.200.36 212.200.200.62;
 option broadcast-address 212.200.200.63;
 server-name "212.200.200.34";
 option domain-name "bla";

 host SID-900111 {
    hardware ethernet 55:47:6d:ed:03:c9;
    fixed-address 212.200.200.36;
 }

 host SID-111334 {
    hardware ethernet 61:5a:6d:ef:cb:b4;
    fixed-address 212.200.200.37;
 }

 ...

}

subnet 212.100.100.96 netmask 255.255.255.224 {
 option dhcp-server-identifier 212.200.200.34;
 server-identifier 212.200.200.34;
 option routers 212.200.200.33;
 option subnet-mask 255.255.255.224;
 option time-servers 212.200.200.34;
 range 212.100.100.97 212.100.100.126;
 option broadcast-address 212.100.100.127;
 server-name "212.200.200.34";
 option domain-name "bla";

 host SID-111109 {
    hardware ethernet 21:4e:6c:ac:09:43;
    fixed-address 212.100.100.97;
 }

 host SID-111110 {
    hardware ethernet 53:4e:6d:da:38:0a;
    fixed-address 212.100.100.98;
 }

 ...

}

}

So, the addresses of the first range (212.200.200.36 - 212.200.200.62) are given out correctly to the devices.

The addresses of the second range (212.100.100.97 - 212.100.100.126) are not, stating an error in the logs: wrong network.

Can you tell me, what I am missing here?

I created a simple graphic file. The DHCP A is not important. The problem exists in DHCP B. DHCP CMTS scenario

6
  • 2
    Have you setup a DHCP helper address in the CMTS configuration? Jun 28, 2019 at 17:00
  • Nope, I did not, I guess, but I have not done that for the first range (which is working) either.
    – vega
    Jul 1, 2019 at 7:23
  • If your DHCP server is directly connected to the network segment it's serving, it needs no DHCP helper and can hand out addresses directly. That seems to be true for your first segment. But if the DHCP server has no interface in the network segment it's supposed to serve, it needs a DHCP helper in that segment.
    – telcoM
    Jul 1, 2019 at 8:33
  • @vega I would advise seeing our DHCP works," TCP Illustrated" vol I 2nd edition helps. Inventing and dreaming up rules all along does not cut it for such complex environments. As telcom implies, DHCP packets are broadcasted, broadcasts do not cross routing. I would also advise seeing CMTS materials about using DHCP helpers. Beware there are also specific ISC-DHCP configurations for cable environments. It is a long time I have left the cable industry, but I would swear a couple of options are missing there. Jul 1, 2019 at 9:21
  • Thanks for the hint. I put it down on my list of books. I think the options are okay so far, as the cable modems are getting their IPs (from the first range) and being online. The tricky thing is just the second range, I believe. So, where should I put/configure a DHCP helper? The CMTS is not in that range, too, but in a private network (like the cable modems at the beginning).
    – vega
    Jul 1, 2019 at 10:19

1 Answer 1

1

Alright, I had two ways now to do it: Either add another NIC to the machine with an IP of the second IP range or try to get a bigger IP range (/26 instead /27).

First, I tried it with the second NIC, which worked out fine.

Later on I received a /26 net and reconfigured everything, so all CMs are in the same net.

Both methods are legit/working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.