I have created a simple EFS and trying to mount it to my AWS EC2 which is using amazon-linux distribution.

I have been following the very simple instructions given there,

I login to the my EC2, then

$ sudo yum install -y amazon-efs-utils

$ sudo mkdir efs

$ sudo mount -t efs fs-9341z1x0:/ efs
Traceback (most recent call last):
  File "/sbin/mount.efs", line 694, in <module>
  File "/sbin/mount.efs", line 690, in main
    mount_nfs(dns_name, path, mountpoint, options)
  File "/sbin/mount.efs", line 480, in mount_nfs
    proc = subprocess.Popen(command, stdout=subprocess.PIPE, stderr=subprocess.PIPE, close_fds=True)
  File "/usr/lib64/python2.7/subprocess.py", line 390, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1025, in _execute_child
    raise child_exception

I am unable to debug this issue. I then created my own NFS server on an ubuntu machine and when I tried to mount that on my amazon-linux machine, I get the following error,

$ sudo mount xx.xx.xx.xx:/home/ubuntu/nfsshare efs
mount: /home/ec2-user/efs: bad option; for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program.

Any help on this?

FYI: This EC2 is built using kubernetes worker node AMI in the ap-south-1 region. I am trying to create PV.

1 Answer 1


Have you looked at the instance profile attached to the host to make sure that it has permission to connect to EFS? You might also want to check the security group that the servers are a part of. I've gotten stuck a few times not thinking about the fact that traversal within a security group is forbidden unless explicitly allowed. For instance, if you setup NFS in the same security group (GroupA) as the server you're attempting to mount, make sure that you're allowing connections from GroupA -> GroupA over the correct port.

Might not be the problem but it's a good place to start.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .