I'm trying to install debian 64bit from a debian live image using YUMI on my usb drive. I'm installing it on an Inspiron 6400, and there is missing firmware. I can't connect to the internet whatsoever, and am at a loss. I've tried configuring it myself to no avail. I downloaded the drivers, transferred them to the laptop, and it wouldn't run the install file because none of the networking directories seemed to exist.

Does anybody have experience with this, or could anybody nudge me in the right direction?



So guys, here's what I did. I figured it out eventually. What I did was download the firmware for the wireless card, put it on a usb drive, bring it to my laptop, and install it. Then I painstakingly downloaded every package and every dependency for wicd-curses, and installed that. Then I connected to my wireless with that, and got internet at this point. I tried getting the wired card to work but after many days I gave up and settled for wireless.

  • 1
    Debian provides an unofficial installer with firmware included: cdimage.debian.org/cdimage/unofficial/non-free/… – jordanm Oct 23 '12 at 22:22
  • How exactly do I use this installer? Will it be on the debian live image, or do I need to download it, transfer it over there, and then use it? Normally standard things like gcc, make, libc, etc are not provided, so things may not work smoothly. I'm quite a noob at this linux thing, thanks for the help. – Scriptonaut Oct 23 '12 at 23:13
  • 1
    The images (e.g. for amd64) jordanm linked are netinst images -- i.e. you can use them to install from the net, they don't include anything but the installer, set up in a way that after having configured a network connection, all the packages you'd like to have (say, the desktop and the laptop "task" bundles) are downloaded and installed. (No idea about using this with YUMI, sorry.) – sr_ Oct 24 '12 at 6:52
  • I think YUMI was my problem. I got the firmware image and am trying it with unetbootin now, and it seems to be installing fine, and it mounted fine. However I get this message: Some of your hardware needs non-free firmware files to operate. The missing firmware files are: b43/ucode5.fw b43-open/ucode5.fw This is the firmware for my wireless card, but if the wired connection is there I can easily download and install it with apt-get. I'll report back if it works, thanks for the tips. – Scriptonaut Oct 24 '12 at 16:40
  • 1
    Did it work? It would be nice if you answered your own question here for future reference. – vonbrand Jan 24 '13 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.