0

Brand new to Brocade or any switch, I managed to configure load balancing without ssl and now working on ssl enabling.

I have a PEM file on my IIS server and I try to copy this to the switch using

pscp bond.pem admin@x.x.x.x:sslcert:jackash:pem

pscp -scp bond.pem admin@x.x.x.x:sslcert:jackash:pem

I get the error -

The first key-exchange algorithm supported by the server is
diffie-hellman-group1-sha1, which is below the configured warning threshold.
Continue with connection? (y/n) y
bond.pem               | 3 kB |   3.4 kB/s | ETA: 00:00:00 | 100%
FATAL ERROR: Received unexpected end-of-file from server

I have enabled scp on brocade. What am I doing wrong here?

  • This question is about a non unix/linux system trying to communicate to an other non unix/linux system (ok newer brocades are using an embedded linux. it's just not very known userland, ssh probably included). The trouble is that what is easy for openssh is perhaps unknown for other clients. Were it openssh i'd say this question is a duplicate. As it's not, I'll just put a link to a similar question – A.B Jun 26 '19 at 20:40
  • you should ask Brocade to give you an up-to-date ssh server. Else see this: How to enable diffie-hellman-group1-sha1 key exchange on Debian 8.0? – A.B Jun 26 '19 at 20:40
  • @A.B Noone wants to own up Brocade anymore. Broadcom has declined to respond. No response from HCL which apparently has ownership over ServerIron ADX 1000.. – WhatsInAName Jun 27 '19 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.