I installed Linux Mint recently, everything seems fine, except my USB 3 drives won't mount when plugged into USB 3, they don't even light up. They will only mount when plugged into a USB 2 port. My USB 2 devices however, work fine in both USB 3 and USB 2. AFAIK, USB 3.0 drivers have been in the kernal for years, so why isn't it working? I believe I had a similar issue in Fedora 30, but I don't currently have it installed, so I can't test it.

Here's what I know:

   *    | Port
Device  | USB 3   USB 2
USB 3   |       |   x
USB 2   |   x   |   x

x: denotes working

lsusb suggests that there are USB 3 drivers installed

Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 1532:021e Razer USA, Ltd 
Bus 002 Device 002: ID 2516:0034  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I followed these instructions USB 3.0 ports not working, but I'm not sure how to determine which driver I need to check the Kernal configuration for, nor where in the very long output from /boot/config- I need to look, or for what to look.

This is what lspci is saying

lspci | grep -i usb
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)

I've also tried editting the grub cmdline to include iommu=soft as suggested in USB 3.0 not working in linux mint , but that didn't work. Possibly the instructions are only for the old GRUB?

Daniel Quinn had the same problem over at USB3 Hard Drive Not Recognised by Linux but his solution is a bit inconclusive, only that his USB 3 is currently working for him. Perhaps it has something to do with the Kernal and toggling options, then rebuilding it changed something?

Any or ideas or suggestions on how I can get this to work?

1 Answer 1


What hardware do you have?

I had an issue with a lenovo laptop in which an usb3 port did not provide enough energy for an external usb3 hard drive when connected via usb3 cable.

Try an usb3 hub with external power supply. Or try to connect the usb3 port and the hard drive with an usb2 cable (speeds will be slower obviously).

Both worked in my case.

  • I've got a Gigabyte U24. This doesn't appear to be the issue in this case as it is occurring with USB3 memory sticks, not hard drives. I totally agree with the power issue for other people who might find this question. Some USB3 hard drives need a Y cable to get enough power sometimes.
    – Kelly Bang
    Jun 26, 2019 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.