0

I am running Ubuntu 16.04. When I am logged in normally and I run a git clone it works without issues -

wesley@localhost:~/Temp$ git clone ssh://git@xyz.pqr.com:5678/abc/myproject.git
Cloning into 'myproject'...
remote: Counting objects: ...
...
...

This works without me needing to enter any username or password or passphrase. My ssh config looks as follows -

wesley@localhost:~/.ssh$ ls -alt
total 56
drwxr-xr-x 97 wesley wesley  4096 Jun 26 10:45 ..
-rw-r--r--  1 wesley wesley 32718 Jun 25 11:44 known_hosts
drwx------  2 wesley wesley  4096 Mar 28 11:09 .
-rw-rw-r--  1 wesley wesley   963 Feb  9  2018 config
-rw-------  1 wesley wesley  3326 May 26  2017 id_rsa
-rw-r--r--  1 wesley wesley   750 May 26  2017 id_rsa.pub

However, let's say I SSH to my own machine with my own user. Then the 'git clone' asks me to "Enter passphrase for key '/home/wesley/.ssh/id_rsa'"

wesley@localhost:~/Temp$ ssh wesley@localhost
wesley@localhost's password:
Welcome to Ubuntu 16.04.2 LTS (GNU/Linux 4.15.0-52-generic x86_64)
...
...
wesley@localhost:~$ cd Temp/
wesley@localhost:~/Temp$
wesley@localhost:~/Dump$ git clone ssh://git@xyz.pqr.com:5678/abc/myproject.git
Cloning into 'myproject'...
Enter passphrase for key '/home/wesley/.ssh/id_rsa':

Why is the behavior different when I SSH?

  • You probably have an SSH Agent running when logged in via the GUI. Probably Seahorse if on GNOME. – muru Jun 26 at 15:04
  • 2
    can you check, if this happens when you enable agent forwarding (ssh -A wesley@localhost)? – blissini Jun 26 at 15:12
  • @blissini, thanks! When I use the -A option the git clone works like before. – Wes Jun 26 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.