0

I am trying to create a custom command in centreon like

 $USER1$/check_icmp -H $HOSTADDRESS$

however before that I just want to test this plugin (that comes with centreon) in my console. For that I write

 ./check_icmp 127.0.0.1

and, for some reason I have a Segmentation fault error.

However yesterday I have tried this command and got

./check_icmp 127.0.0.1
OK - 127.0.0.1 rta 0.033ms lost 0%|rta=0.033ms;200.000;500.000;0; 
rtmax=0.054ms;;;; rtmin=0.023ms;;;; pl=0%;40;80;0;100

When I screen my plugins in centreon they appear in red for some reason (maybe due to the s flag)

enter image description here

What might be wrong?

2
  • The syntax in the first line has a -H that you're not showing in the remaining examples; is that the issue?
    – Jeff Schaller
    Jun 26, 2019 at 12:19
  • No, I am not using -H right now. Just showed it as an example of centreon command. The only syntax I used was ./check_icmp 127.0.0.1 and it worked. I just don't understand what that segmentation fault error means? I cannot find a clear answer elsewhere.. Jun 26, 2019 at 12:48

0

You must log in to answer this question.

Browse other questions tagged .