I'm trying to link a a library, libmkl_rt.so, while compiling Julia in Fedora 30. The library is located in /opt/intel/compilers_and_libraries_2019.4.243/linux/mkl/lib/intel64_lin/.

Running ld -lmkl_rt results in "ld: cannot find -lmkl_rt"

Manually specifying the location works as expected:

ld -L/opt/intel/compilers_and_libraries_2019.4.243/linux/mkl/lib/intel64_lin -lmkl_rt results in "ld: warning: cannot find entry symbol _start; not setting start address"

I've tried adding this location to the LD_LIBRARY_PATH environment variable, which is empty by default, and I've tried creating a file within /etc/ld.so.conf.d called "mkl.conf" containing only the library's path, then running ldconfig. Neither of these allows ld to find the library.

How can I get ld to search this path?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.