0

I am unable to install debian 9 as a guest operating system in virtualbox 6.0, either with a debian 9 host or with a Windows 10 host. - I installed virtualbox per the instructions on the debian wiki, updating my sources.lst and adding the oracle vbox public key:

https://wiki.debian.org/VirtualBox

  • I did install virtualbox 6.0 - the wiki is out of date and refers to 5.2. (I installed 5.2 first on my debian system, but removed it after the failures described below, hoping that the newer version would correct those.)
  • Virtualbox appeared to have installed with no reported problems, both on debian and on Windows.
  • I downloaded debian-live-9.9.0-amd64-gnome.iso, since that was a bootable image.
  • I checked its sha256 to confirm.
  • I burned the image to a dvd, with verification, and installed from the dvd.
  • My Windows 10 box and my debian box are both 64 bit.

  • I am able to install up to the point of downloading from a mirror.

  • At this point, it appears that several files are downloaded, showing messages like "file 5 of 18...", at which point I am presented with a failure message and the choice to retry, try another mirror, or ignore.
  • I have both retried and have tried several mirrors with the same results.
  • My Internet connection is solid and reliable - I have experienced no other difficulties.
  • If I 'Ignore', the installation proceeds to the point of attempting to install the grub bootloader, at which point it fails.
  • I have used defaults for both virtualbox and for debian, and have not tinkered with any of the suggested settings.

There are dozens of pages on the Internet apparently describing the exact steps I took, but for all those bloggers the installation "just worked". There are a number of reports of people experiencing difficulties installing the Guest Additions, but that is a separate issue that I have not gotten far enough to worry about.

I would like to think this is some simple setting I have overlooked or step I have missed. Any clues or suggestions are appreciated.

------------ UPDATE 1 ----------

Based on similar issues found on googling the error message below, I have disabled the network, declined to use a mirror, and jumped ahead to the second error, which is the killer:

"The 'grub-pc' package failed to install into /target/."

At this point I have exited to a shell to try to manually install grub, which should (?) exist in some form on my install media (DVD, ISO, whatever...). A network connection should not be required at this point. However, I have tried this both with and without re-enabling the network connection. No joy.

In the shell, I am unable to find apt, or apt-get, or dpkg, and so have not been able to manually install grub. I think that if this point I could get grub installed so that this VM instance would boot, I could correct any remaining issues. Can someone help me through this next step?

------------ UPDATE 2 ----------

After getting zero responses in over a week I have given up on this and am using qemu. Qemu of course has a learning curve of its own, but I was at least able to create a functioning basic guest system fairly quickly. VirtualBox has been fairly painless for me with a Windows Host, and with a Windows guest and an older Ubuntu host. It would be interesting to know what the issue is here.

0

• I downloaded debian-live-9.9.0-amd64-gnome.iso, since that was a bootable image. • I checked its sha256 to confirm. • I burned the image to a dvd, with verification, and installed from the dvd.

The .iso you use for VirtualBox simply needs to be stored on your H/SDD, not burned to DVD media.

  • Yes, of course you can install from a variety of media types, and I have installed different operating systems to Virtual Box both from images and from DVDs. Please explain why this would make the slightest difference to why the install would fail or succeed in the way I observed. A problem reading the media would likely present a different set of symptoms, and in fact I see the identical failure when I read the iso directly. – mickeyf Jun 25 at 11:54
  • By the way, this may be helpful to future readers as a comment, but unless it solves or helps to explain the problem it should not really be posted as an answer. – mickeyf Jun 25 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.