1

After installing Linux Mint, I had a problem with the hard drive (more than 200GB) getting full without me downloading anything. This was probably because of timeshift and some users said it also had to do with not setting up the partitions properly.

I tried to reinstall Mint and erase the hard drive that way, but when I start it through my USB, nonstop lines of “PCIE Bus Error: severity=corrected, type=Physical Layer” show up. Only OEM mode worked, so I started the installation but it froze after finishing copying files. I rebooted my laptop and now it only shows “GNU GRUB version 2.02”.

Is there a command to erase my hard drive so I can reinstall Mint or does the problem lie in something else? I know the USB containing Linux Mint works because I tried it on another computer.

Edit: From another thread, I found the boot parameter “pcie_aspm=off”. Adding it to the end of the line starting with “Linux”, erasing the last “--“ before however, I was able to live boot Mint. I had erased partitions and made a new efi partition with Gparted on a different Ubuntu liveUSB. Installed mint and works again, except that CPU usage goes to 100% for no reason and when shutting down, the “PCIE Bus error” lines show up again. Looking into it.

Thread: https://forums.linuxmint.com/viewtopic.php?t=245241

Edit 2: adding the boot parameter “pcie_aspm=off” to the kernel fixed the issue.

1

Based on a thread on a different question on the StackExchange network, you may be able to circumvent the "PCIE Bus Error: severity=corrected, type=Physical Layer" error by starting the OS by adding one of the following kernel boot parameters when loading from GRUB:

pci=nomsi

or

pci=noaer

source: https://askubuntu.com/questions/771899/pcie-bus-error-severity-corrected

It might not fix your underlying problem, but maybe it'll give you some clues if you could start up the system despite the issues.

As far as the hard drive problems are concerned, I would completely reset the partition table from scratch (assuming you're not trying to preserve part of the hard drive) and choose a standard Linux-compatible filesystem (e.g. ext4, etc). This can be done on the command line via commands like fdisk and mk2fs.ext4 (these may or may not be included in Mint, I'm not sure).

  • Thanks, I don’t know how to launch the OS from GRUB yet but I’ll try to figure it out. If it works I’ll get into the partitions. Should I worry about the partitions after reinstalling the OS, if it works, or is that something I do during/before the installation? – ninjaone Jun 24 at 18:59
  • I followed the instructions on the link you gave and it worked! I was able to launch the OS from my Flash Drive and currently installing it. Thank you! – ninjaone Jun 24 at 19:12
  • Great, sounds good. Always glad to help out a fellow Linux user. – Jason K Lai Jun 24 at 19:21
  • Sorry, that comment was premature. While installing, it froze again. A note came up that said there were 0 bytes free space left on the computer. I turned off the computer, tried both commands for booting up, but the error came up again. I think I have to erase my hard drive somehow for it to work, not sure. – ninjaone Jun 24 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.