0

I've upgraded from Fedora 29 to Fedora 30. Alghough root can use KDE normally, I fail to use it as a normal user, so it seems permission related. An almost black fullscreen window appears with a responsive mouse arrow in the middle of the screen. Some data that may be relevant:

I am seeing problems with /lib64/libQt5DBus.so.5, even after reinstalling it.

I don't see any error in the normal user Xorg.0.log file, I can post it if needed.

I have also seen some errors related to kglobalaccel, but removing the .local, .config and .kde folders did not help either. But journalctl says (not sure what to do with this):

systemd[1133]: Started dbus-:1.2-org.kde.kglobalaccel@0.service.
kglobalaccel5[1531]: qt.qpa.xcb: could not connect to display
audit[1531]: ANOM_ABEND auid=500 uid=500 gid=500 ses=2 pid=1531 comm="kglobalaccel5" exe="/usr/bin/kglobalaccel5" sig=6 res=1
kglobalaccel5[1531]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
kglobalaccel5[1531]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
                     Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
systemd[1]: Created slice system-systemd\x2dcoredump.slice.
audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-coredump@0-1537-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
systemd[1]: Started Process Core Dump (PID 1537/UID 0).
dbus-broker-launch[1483]: Activation request for 'org.freedesktop.Telepathy.Client.KTp.Approver' failed.
dbus-broker-launch[1483]: Activation request for 'org.freedesktop.Telepathy.Client.KTp.KdedIntegrationModule' failed.
systemd[1133]: dbus-:1.2-org.kde.kglobalaccel@0.service: Main process exited, code=dumped, status=6/ABRT
systemd[1133]: dbus-:1.2-org.kde.kglobalaccel@0.service: Succeeded.
systemd-coredump[1541]: Process 1531 (kglobalaccel5) of user 500 dumped core.

                                            Stack trace of thread 1531:
                                            #0  0x00007fd273722e75 raise (libc.so.6)
                                            #1  0x00007fd27370d895 abort (libc.so.6)
                                            #2  0x00007fd273b33af5 _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                            #3  0x00007fd2740dc29f _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv (libQt5Gui.so.5)
                                            #4  0x00007fd2740dcaf8 _ZN22QGuiApplicationPrivate21createEventDispatcherEv (libQt5Gui.so.5)
                                            #5  0x00007fd273d16975 _ZN23QCoreApplicationPrivate4initEv (libQt5Core.so.5)
                                            #6  0x00007fd2740de253 _ZN22QGuiApplicationPrivate4initEv (libQt5Gui.so.5)
                                            #7  0x00007fd2740df198 _ZN15QGuiApplicationC2ERiPPci (libQt5Gui.so.5)
                                            #8  0x0000555c57159481 n/a (kglobalaccel5)
                                            #9  0x00007fd27370ef33 __libc_start_main (libc.so.6)
                                            #10 0x0000555c571597de n/a (kglobalaccel5)

Look at some console output:

Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86MonBrightnessCycle
> Internal error:   Could not resolve keysym XF86RotationLockToggle
Errors from xkbcomp are not fatal to the X server
startkde: Starting up...
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.InvalidArgs: Invalid environment assignments
Connecting to deprecated signal QDBusConnectionInterface:serviceOwnerChanged(QString,QString,QString)
Cannot find �rg.kde.KSplash.setStage' in object /KSplash at org.kde.KSplash
kf5.kded: found kded module "colord" by prepending 'kded_' to the library path, please fix your metadata.
Qt: Session management error: networkIdsList argument is NULL 
colord: "/home/gato/.local/share/icc/.." is not an ICC profile
colord: "/home/gato/.local/share/icc/." is not an ICC profile
(II) AIGLX: Suspending AIGLX clients for VT switch
The X11 connection broke (error 1). Did the X11 server die?
kdeinit5: Fatal IO error: client killed 
kdeinit5: sending SIGHUP to children.
klauncher: Exiting on signal 1
kdeinit5: sending SIGTERM to children.
kdeinit5: Exit.
Unexpected response from KInit (response = 0).
startkde: Could not start ksmserver. Check your installation.
Error: Can't open display: :0.0
(II) Server terminated successfully (0). Closing log file.
xinit: connection to X server lost
GOT SIGHUP
Antares:~> startkde: Shutting down...
kdeinit5_wrapper: Warning: connect(/run/user/500/kdeinit5__0) failed: : No such file or directory
Error: Can not contact kdeinit5!
xprop:  unable to open display ':0.0'
xprop:  unable to open display ':0.0'
startkde: Done.

Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.NoReply", "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.")
The X11 connection broke (error 1). Did the X11 server die?
  • BTW, I can run KDE as a second normal user. I tried moving the ~/.kde* ~/.config and ~/.cache stuff without any luck. – Luis A. Florit Jun 24 at 17:39
0

The problem was that the new xinit is incompatible with my old .xinitrc file. I added the content of .xinitrc to .profile and everything worked again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.