1

I am running Debian 9 with LXDE on a LattePanda and the main monitor is defaulting to the Internal Display that does not exist. I want to disable the internal display so each time it boots up to the HDMI monitor.

I am familiar with using xrandr like in this solution, but the terminal always opens on the non-existent internal display. So I can't execute it

I tried updating the BIOS option to force the laptop lid to be closed, but that doesn't fix it.

Does anyone know of another way to disable the internal monitor by default? I have to flash several LattePandas which could all have a similar issue.

xrandr output

DP-1 disconnected primary (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 connected 1600x900+0+0 (normal left inverted right x axis y axis) 442mm x 249mm
   1600x900      60.00*+
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
DSI-1 connected 1024x600+1600+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x600      60.00*+
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  

lspci output

00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:03.0 Multimedia controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)
2
  • Could you provide more information about the internal display device? Output from lspci, and xrandr, etc.
    – oxr463
    Jun 24, 2019 at 13:01
  • @LucasRamage sure, just added it to my question
    – cbolles
    Jun 24, 2019 at 13:08

2 Answers 2

1

Found a solution that lets me disable the internal monitor.

  1. Boot into Recovery Mode and login as root

This is important, it allows me to access the command line from the HDMI monitor which I couldn't do normally

  1. Edit /etc/default/grub

Change

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=DSI-1:d"
  1. Run update-grub

Now the system boots up without the internal monitor. Credit to a comment made by @Dmitry

0

There are a few methods one could employ,

1) Completely disable graphics on boot, such as in this answer.

2) Blacklist the kernel module for the video device.

1
  • 1
    Thanks for the help, the main issue was that I couldn't access the terminal since it would always open on the non-existent internal monitor. I ended up finding out that booting into recovery mode allowed me to use the HDMI monitor
    – cbolles
    Jun 24, 2019 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .