1

I have a problem installing Pandas under Python 3.7.3 on a MOXA linux computer running Debian 9. It has a Armv7 Cortex-A8 600-1000 MHz processor.

I tried:

sudo apt update
sudo apt ugrpade
sudo apt install python3-pandas 
sudo apt-get install python3-pandas 

The last two commands have the following error:

python3-pandas : Depends: python3-pandas-lib (>= 0.19.2-5.1) but it is not installable)

And:

sudo pip3 install pandas
sudo pip3 install pandas -v

(to see in running) (takes ages to install, but eventually stops)

I installed every needed package (numpy, matplotlib, setuptools, pytz, python-dateutil, etc) but I still get errors.

Also it says: you have held broken packages. When I googled that, the command to list of actual held packages:

dpkg --get-selections | grep hold

It returns nothing, so there are no held packages?

Any ideas?

UPDATE: Output of uname -a: Linux AAGCloudWatcher 4.4.0-cip #1 Wed Mar 27 13:53:48 CST 2019 armv7l GNU/Linux

  • What is the results of uname -a? The repository that your arm based version of Debian may not have the package. But please edit your post to include the output of uname -a. – kemotep Jun 24 '19 at 12:45
  • See update message of result uname -a – Observatory Gromme Jun 24 '19 at 17:24
2

According to this page, python3-pandas-lib is built for arm and arm64 and available in the official stretch repositories.

According to your recent update, your system identifies as armv7l which would need the armhf repository branch from Debian. It does not appear that python-pandas is available for armhf in Debian stretch, but is built for jessie and buster.

The pip install should attempt to build it for your machine, but there may be some incompatibility that prevents this version from working properly with armv7l which could be why it is not included in Debian stretch.

  • Thank you. So any suggestions how to still get this working? Or is this a lost of time and will pandas never work on armv71? – Observatory Gromme Jun 24 '19 at 20:06
  • @ObservatoryGromme as user GracefulRestart points out there is a version for Buster. Debian Buster will be releasing in the next few weeks. If it is possible you can update to that to get the package you need. If not you will need to change to a distribution that has all the packages you need. – kemotep Jun 24 '19 at 20:35
  • @kemotep thank you very much for more pointing out to me. i'm really new on all this programming. I will just wait and install the fresh debian 10(buster). Thank you all – Observatory Gromme Jun 24 '19 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.