0

Put simply WiFi isn't working on the laptop. The network card which is of the ath10k variety has been bad in the past, but now it is simply not working. The laptop is running linux mint 19.1. I have tried installing new drivers to /lib/firmware/ath10k, I have tried updating my kernel to 4.19, I have tried fixing my kernel update, I have tried creating a driver configuration file and I have tried turning off wifi powersave in NetworkManager and TLP. Here's the output to some diagnostic commands.

inxi -Fxxxz https://pastebin.com/hsc93MW7

lspci | grep ath no output

sudo lshw -C network no output

dmesg | grep ath [ 63.835354] ath10k_core: unknown parameter 'nohwcrypt' ignored [ 63.836722] ath10k_pci: unknown parameter 'nohwcrypt' ignored [ 63.836723] ath10k_pci: unknown parameter 'skip_otp' ignored

lspci -nnk | grep 0280 -A3 no output

sudo modprobe ath10k_pci no output

  • Your inxi only shows a Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb. Is this a replacement adapter and the Atheros card is disabled in BIOS? – Freddy Jun 24 '19 at 1:57
  • I run mint on one of my Dell laptops also with that ath (mini card). Mine showed up w/o issue. What happens if you press the FN key and the Wireless key on your keyboard. Does the card suddenly show up? – somebody Jun 24 '19 at 6:05
  • The Ralink is simply a replacement adapter. I just tried to turn the atheros card off and then back on in BIOS. This did not work. I also tried the wireless key. I know for sure that the integrated wireless card (atheros) is still working somewhat because bluetooth is showing up and it is a combined bluetooth and wireless card. – Mark Muchane Jun 24 '19 at 12:15
0

This is what worked for me. I deleted /lib/firmware/ath10k. I then ran these two commands. The first fixes firmware and gets the latest version, the second turns off some wifi powersaving features. I did this on kernel 4.19.

sudo apt-get install --reinstall linux-firmware
sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.