0

Every time I record or screencast my desktop, once I play it back I get random lines appearing now and then, no matter what media player I use. They're either black or they show fragments of my desktop underneath. I used all the most famous programs out there, including:

  • Kazam
  • OBS Studio
  • SimpleScreenRecorder

and others, but always with the same lousy result. Any idea on how to fix this annoying problem? I'm adding my linux-box software-hardware data below with 'inxi'

System: Host: TheBigX Kernel: 4.15.0-52-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10 wm: muffin dm: LightDM Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic Machine: Type: Desktop Mobo: Gigabyte model: B85M-DS3H-A v: x.x serial: N/A BIOS: American Megatrends v: F1 date: 01/19/2015 CPU: Quad Core: Intel Core i7-4790 type: MT MCP arch: Haswell speed: 2467 MHz min/max: 800/4000 MHz Graphics: Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: ASUSTeK driver: nvidia v: 430.26 bus ID: 01:00.0 chip ID: 10de:1401 Display: server: X.Org 1.19.6 driver: nvidia resolution: 1920x1080~60Hz OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 direct render: Yes Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 Drives: Local Storage: total: 931.51 GiB used: 113.97 GiB (12.2%) Info: Processes: 261 Uptime: 1h 22m Memory: 15.63 GiB used: 2.06 GiB (13.2%) Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash v: 4.4.19 running in: gnome-terminal inxi: 3.0.27

Thank you in advance for any help you can provide.

Regards

Saverio

0

Well, apparently I was able to fix the issue, which was caused by the nvidia driver (what a surprise). After upgrading to Linux Mint 19.1 and after installing the latest nvidia driver, all I had to do was to open the nvidia-settings control panel, click on the 'Open GL settings' section and disable both 'sync to VBlank' AND 'Allow Flipping'. That did, for me at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.