1

I have two laptops, one running CentOS 7 and recently installed latest RHEL 8 on another one. The issue is that I am unable to launch any X program from RHEL 8 over ssh -X but reverse works okay (tried various, xeyes, gnome-terminal, calculator etc) . Let me elaborate

  1. firewall on both the machines are disabled
  2. X11Forwarding is set to yes on box the laptops by default (/etc/ssh/sshd_config)
  3. from CentOs 7, ssh -X root@rhel8 to login to RHEL 8 box.
  4. from ssh shell, echo $DISPLAY shows localhost:10.0
  5. from ssh shell, launch gnome-terminal. I expected this to be shown on centos laptop display but instead it shows on RHEL 8 laptop itself.

Interestingly, if I do the reverse, login to CentOS 7 from RHEL 8 using `ssh -X' and try to run any program in ssh shell, it is showing on RHEL8 laptop as expected.

Is there anything changed in RHEL8 the way X Forwarding works?

  • 2
    Do you have the same problem with programs like xterm, xev or xeyes or just with gnome-terminal? gnome-terminal is known to implement its own "application server", completely ignoring and breaking the X11 model, users' expectations, and any sane software engineering principles ;-) – mosvy Jun 23 '19 at 7:47
  • every thing, even gnome-calculator – Rahul Jun 23 '19 at 16:23
  • 1
    Are you sure you're running X11 and not Wayland on the RHEL8 machine? Please also try with some classical X11 app like xev(1), xlogo(1) or xclock(1) not just some gnome-*. – mosvy Jun 23 '19 at 16:41
  • nothing working, not even xeyes. Also, I like to use gnome-terminal all of which works fine with CentOS 7. So kindly answer only if you have used RHEL 8 and solved this. – Rahul Jun 23 '19 at 17:00
  • 2
    I have used RHEL8 with X11 forwarding, but I won't annoy you anymore. – mosvy Jun 23 '19 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.