0

I have been working on a computer which apparently has Debian buster as well as MS-Windows 10 1903 . On the said machine before you could copy and paste files and folders without an issue. In some update, it seems you can no longer do file and folders copying from one to the other. I haven't yet tried from MS-Windows to Debian as it needs a third-party driver and there wasn't much development heppening on that the last time I looked at.

FWIW, in this particular system I am dual-booting. Installed Win10 first and Debian GNU/Linux afterwards. I do use linux like 99% of the time but there are times when I have to use MS-Windows.

I do get these errors while trying to do using caja -

caja:2887): GLib-GObject-WARNING **: 21:26:45.272: invalid (NULL)
pointer instance

(caja:2887): GLib-GObject-CRITICAL **: 21:26:45.272:
g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)'
failed

(caja:2887): GLib-GObject-WARNING **: 21:26:45.272: invalid (NULL)
pointer instance

(caja:2887): GLib-GObject-CRITICAL **: 21:26:45.272:
g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)'
failed

(caja:2887): EggSMClient-CRITICAL **: 21:26:45.272:
egg_sm_client_is_resumed: assertion 'client == global_client' failed

Although just had an update of libfm-qt6 https://tracker.debian.org/news/1040963/accepted-libfm-qt-0141-9-source-into-unstable/

  • You should possibly mention how you are running the two operating systems side by side. – Kusalananda Jun 22 at 15:50
  • @Kusalananda I think the OP means copying files from the NTFS Windows partition into their Debian partition while running Debian. I think the OP is dual booting. – Giraffer Jun 22 at 16:10
  • @shirish, could you please post any errors you receive when copying the files using cp. – Giraffer Jun 22 at 16:12
  • @Giraffer Oh, I thought maybe they were running one OS in a VM on top of the other and tried to use the clipboard or some file manager copy-paste-thingy. – Kusalananda Jun 22 at 16:26
  • @Giraffer updated my query with the errors I am/was recieving. – shirish Jun 25 at 13:21
0

If you get one of the following error messages while mounting an NTFS partition (the first is my Win10 partition, the second is my data partition)

root@debian:~# mount /dev/sda2 /mnt/winc
Windows is hibernated, refused to mount.
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

root@debian:~# mount /dev/sda7 /mnt/wind
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

then you need to disable fast startup in Win10 or shutdown Windows while holding the Shift key.

  • In the system I am using, playing with it has disabled fast startup and am able to access ntfs partition, just not able to copoy files to it. Let me recheck again and will get back to you. – shirish Jun 25 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.