0

I tried to change my wireless adapter to monitor mode from managed mode using airmon-ng and iwconfig method both and I ended up with 'auto' mode for my adapter which I am not able to change back to managed.(and I'm unable to connect it to any network as it is kind of not detected by Kali) *Driver (wireless adapter)- r8188eu *Chipset (wireless adapter)- Realtek Semiconductor Corp RTL8188EUS 802.11n . Please guide me.(I suspect my adapter does not support monitor mode, but how do I make it normal like before?)

1

Try removing the kernel module and reloading.

Maybe

sudo rmmod r8188eu

removes module

sudo lsmod | grep r8188eu

list kernels mods loaded and filter with grep, should return nothing, e.g. no module loaded

Make changes to the config file of your wireless adapter, to the setting that works, then try loading the kernel module again.

sudo modprobe r8188eu

If it the module doesn't support a mode, it might crash the module and then you get unpredictable behaviour.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .