1

I have a dell studio 1569 and just installed linux onto it. I noticed that the cpu has been running high due to systemd-udevd. Going though different posts on the web including this one, I used "udevadm monitor" to help narrow down what was happening, and here is the output:

udevadm monitor output

I first assumed a usb, so I plugged in and unplugged from all ports but soon discovered it did not have the same path as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2/2-1.6.2:1.0 (usb), then long story short, while I had udevadm monitor running, I pushed some keys on my keyboard and noticed that the path was the same for the keyboard (as seen in the picture above), only difference was the beginning of the line had aKERNEL in front of it instead of KERNEL or UDEV.

My next test was while I had udevadm monitor running, I took apart my laptop and disconnected the keyboard to see if those bind/unbind entrys would stop. But they continued, which makes me now think this is not the keyboard. Can someone know of what else it could be if it is not the keyboard?

Here is the output from lsusb -t: lsusb -t output

EDIT: In case anyone else is running into an issue similar to mine, disabling the bluetooth in the BIOS seems to fix the issue. Refer to this post.

0

I do not have a Class=Hub entry, and I have Driver=xhci_hcd as root_hub...I know from do-it-yourself installations (well, boot experiments) that without a "modprobe xhci-pci" my keyboard stays dead.

But I want to say I had the same problem with one of the kernel/initrd combinations I tried lately. I noticed a silly reconnect every 5 seconds in the kernel messages.

...and just installed linux onto it.

hmm...any details? This kind of problem is exactly what systemd should take care of... I would say the problem is not "the keyboard" but the udevd-configuration of the usb-subsystem.

Edited:

Well if that solves the problem...

Your udevadm shows clearly that UDEV (the hotplug daemon) is doing bind and unbind like crazy.

  • So I don't see how the answer from this post worked but disabling bluetooth in the bios seems to have fixed the issue. I'm just confused because the path I was getting from udevamd monitor was the keyboard, but I guess it works now. – Kayracer Jun 22 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.