0

My /tmp directory is too small which results in an error when I try to commit an image via buildah:

$ buildah commit $container foo:bar
...
error storing layer "42" to file: write /tmp/buildah317710758/layer: no space left on device
ERRO[0008] exit status 1

How can I tell buildah to use a different directory for temporary files? I tried with the following environment variables

TMP=/mytmp
TMPDIR=/mytmp
TEMP=/mytmp

without luck.

  • Does putting an export in front the declaration change anything, e.g., export TMPDIR=/mytmp? – doneal24 Jun 21 '19 at 18:52
  • sadly no, this doesn't change anything – Max Maier Jun 21 '19 at 19:13
  • @MaxMaier: Setting TMPDIR definitely works. – Richard Gomes Oct 19 '20 at 10:14
0

Just define TMPDIR like the example below:

$ export TMPDIR="${HOME}/tmp/buildah"
$ mkdir -p "${TMPDIR}"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.