1

I'm running a Lenovo Legion Y7000P with Pop OS 18.04. My ISP is AT&T. My WiFi tests at about 20Mbps down, 5Mbps up, but my ethernet-over-power set, which is rated for 600Mbps up/down, only gets 10Mbps down, 6Mbps up, and my other laptop can easily reach 30Mbps down, so I doubt it's the network of the ISP causing the problem.

$ sudo lshw -c network gives:

  *-network                 
       description: Wireless interface
       product: RTL8822BE 802.11a/b/g/n/ac WiFi adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlp7s0
       version: 00
       serial: 80:2b:f9:da:38:1b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=r8822be driverversion=4.18.0-20-generic firmware=N/A ip=192.168.1.67 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:141 ioport:4000(size=256) memory:a4300000-a430ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: enp8s0
       version: 15
       serial: e8:6a:64:43:bb:57
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.76 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:17 ioport:3000(size=256) memory:a4204000-a4204fff memory:a4200000-a4203fff

$ ethtool enp8s0 gives:

Settings for enp8s0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes
  • Ethernet over power is probably not ideal, especially if you are crossing breakers. Have you tried a different ethernet cable though to rule out a bad/worn tip? What is the length of the cable as well? Is it cat5e? cat6? – Jesse_b Jun 21 at 14:42
  • The cable is brand new. I don't have any alternatives except ones that definitely are worn out. I know eth over power isn't ideal but I can't reach my modem by ethernet – embradley Jun 21 at 14:43
  • 1
    It seems suspicious that it's only connecting at 100Mb/s. Seems like the cable may be wired incorrectly or have a broken line somewhere. – Jesse_b Jun 21 at 14:45
  • 1
    Ethernet over power easily degrades to lower speeds depending on your wiring and the distance of the adapters (tested in my house). Test yourself by taking two laptops, putting the adapters into different sockets, and measuring the speed laptop-to-laptop (using e.g. iperf). – dirkt Jun 21 at 17:23
3

Very unlikely to be an Ubuntu problem.

  1. Before you wonder, the fact that it connects at 100Mbs instead of 1GBs is normal, many PLC adapters only have 100Mbs ports.
  2. It is very likely a matter of PLC signal scrambled by something else, which could be the power unit of your laptop:

    • Try connecting by ethernet directly
    • Unplug at least momentarily all possible sources of power line noise, power units, USB chargers...

(in my place (FTTH) the Wifi (200Mbs) is somewhat faster than the Ethernet/PLC (70Mbs)(but less releiable...))

  • 1
    How could the PLC adapter claim 600Mbps if it only has 100Mbps ports? – Jesse_b Jun 21 at 15:04
  • 3
    Ask the manufacturers... Some will tell you that the adapter has two 100Mbs ports, so that's 200Mps. But the nominal speed is vastly above the practical limits. I discovered this limitation when I tried to connect two PCs (two Lenovos, btw) by connecting them to the two ports of the same PLC adapter (Devolo, no some no-name thing) and got a max speed of 100Mbs. Bought a 4-ports 1Gbs switch, and got the 1Gbs bandwidth between the two... So Linux (Ubuntu in my case) can handle the speed. – xenoid Jun 21 at 15:14
  • Well my adapter also claims 600Mbps and has gigabit ports – Jesse_b Jun 21 at 15:27
0

Ethernet-over-power is a bad idea to start with. You cram a high-frequency signal into a cable designed for 50Hz, so there are no guarantees it will reach full speed, or even work at all.

I know people who returned such sets because it never worked well for them, and others who returned them because a high-frequency signal pushed in a long unshielded cable created all sorts of interference with their wireless equipment like cordless phones or FM radios. Others yet had to remove the set after their neighbours complained to their local equivalent of FCC about the electromagnetic interference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.