1

with Debian Jessie my Raspberry Pi was working pretty well with booting from NAS. With Stretch there is an issue with shutdown (and reboot), because Stretch seems to disable the network interfaces too early during the shutdown process and thus the Pi hangs.

By doing the following change in

/etc/systemd/system/network-online.target.wants/networking.service

Before: ExecStop=/sbin/ifdown -a --read-environment --exclude=lo
After: ExecStop=/sbin/ifdown -a --read-environment --exclude=lo --exclude=eth0

the boot process works again, but this is, obviously, a hack. Why is Debian Stretch not following the right order of shutting down services when nfsroot is enabled? Or is there any setting that needs to be changed in order for it to work?

I have searched a lot but unfortunately I couldn't find a generic solution.

Help is much appreciated!

Thanks!

Bye

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.