I installed Debian 10 on an Asus notebook. As soon as I installed the Wi-Fi was not working. My WIFI chip is

MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

I installed the package firmware-misc-nonfree but Debian still didn't found the WiFi chip so as suggested in many forum I installed this driver https://github.com/neurobin/MT7630E. As soon as I installed it everything worked fine.

The problems started when I try to connect to another Wifi. The network manager start searching forever a new Wifi using 100% of one core of the CPU without possibility to stop the process(I tried all possible command for stopping the NetworkManager, like stopping the service and kill the process). I tried to wait until it stop but after hours it never stop.

I tried to reboot and shutdown multiple time and the only way to make the Wifi working again is to shoutdown the notebook by hold down the power button.

How can I solve this problem?

EDIT: The workaround I'm using consist to install the driver(the one from Github) at startup and uninstall before shutdown. It's not a solution but it's the only way to not hold down the power button.


Your best chance is to abandon your current driver source, since it's declared in search of a new maintainer ( https://github.com/neurobin/MT7630E/issues/90 ) and is using an old code dump from vendor.

Instead, you should rely on the newly available upstream linux driver available since kernel 4.20:

CONFIG_MT76x0E: MediaTek MT76x0E (PCIe) support General informations

The Linux kernel configuration item CONFIG_MT76x0E:

prompt: MediaTek MT76x0E (PCIe) support
type: tristate
depends on: ( CONFIG_MAC80211 ) && ( CONFIG_PCI )
defined in drivers/net/wireless/mediatek/mt76/mt76x0/Kconfig
found in Linux kernels: 4.20, 5.0–5.1, 5.2-rc+HEAD
modules built: mt76x0e

Help text

This adds support for MT7610/MT7630-based wireless PCIe devices. Hardware PCI

Numeric ID (from LKDDb) and names (from pci.ids) of recognized devices:

vendor: 14c3 ("MEDIATEK Corp."), device: 7630 ("MT7630e 802.11bgn Wireless Network Adapter")
vendor: 14c3 ("MEDIATEK Corp."), device: 7650

Debian 10 will ship with kernel 4.19. As long as it's frozen sid/unstable will only provide upgrades for Debian 10, so also only provides 4.19. You can use an experimental 5.0.x package, from Debian experimental (which isn't updated often), or manage to compile a Debianized kernel using https://salsa.debian.org/kernel-team/linux (steps aren't that trivial), or simply compile a vanilla kernel. It might one day appear in Linux backports for 4.19, but I don't know more than giving the previous link.

There are anyway other issues currently with this driver, for example somebody repoted problems when system is woken up from sleep.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.