I have a directory that was originally all ".doc" files and were copied over to an external hdd. Now all the files are 'binary' files. Some have extensions, many do not.

I tried opening them with the following commands after making them executable, and separately, without making them executable.

chmod +x filename.bin (or filename.chk) 

For example: chmod +x file.chk This resulted in $ on the next line.

./filename.bin (or ./filename.chk)

For example: ./file.chk This resulted in "cannot execute binary file" "exec format error".

I want to open these files just like you would open a word document so I can read the contents.

closed as off-topic by Michael Homer, Andy Dalton, Jeff Schaller Jun 23 at 12:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller
If this question can be reworded to fit the rules in the help center, please edit the question.

  • If the files were .doc before, that generally suggest that they were MS Word documents. If so, why are you trying to execute them? – Andy Dalton Jun 21 at 3:37
  • For the commands above, the person who wrote that suggestion stated to first make sure they are executable. I tried it without and with 'executable' - same result. I have not seen the ext ".bin" on any of them, just ".chk" or no ext. Thanks. – sgu55 Jun 21 at 3:38
  • Can you please update your question with the output of file filename (for some filename) – Andy Dalton Jun 21 at 3:40
  • Website with the instructions: cyberciti.biz/faq/… – sgu55 Jun 21 at 3:48
  • 2
    X-Y. Unknown what you're asking. – 炸鱼薯条德里克 Jun 21 at 3:56

Simply, the reason the files are binary is because they are encrypted - so they are not corrupted. They must be opened using windows OS (not linux) and other non-binary files accompanying the binary ones.

Not the answer you're looking for? Browse other questions tagged or ask your own question.