0

I am trying to install Google Assistant on my Raspberry pi using this tutorial: https://pimylifeup.com/raspberry-pi-google-assistant/

The difference is that I am using a Waveshare WM8960 Audio HAT instead of the built in HDMI or analog audio out. When I try to run the script I get a couple of audio device related errors, which I believe has something to do with the configuration.

Now I'm not that familiar with Raspbian so I can't figure out the issue. I'm using the latest Raspbian Stretch on a Raspberry pi 2 with the correct drivers for the Audio HAT. It functions properly under normal use. The errors I'm getting are as follows when I try to run the script in the virtual python environment:

audio related errors

I have also configured the asoundrc file according to the tutorial by finding the hardware and device id for the HAT:

config for HAT

If anyone has a clue to how I can fix this please let me know. Also if further information, logs, or configuration info is needed I'll happily provide it.

  • Please past text as text. Reading text in images is hard, especially for blind people, or search robots. – ctrl-alt-delor Jun 20 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.