0

I'm trying to set up two new accounts in a Redhat 6.10 environment. The first account that I created works fine no issues. I used the same steps and the second account is unable to login via ssh with putty.

Error Message: Access denied Using keyboard-interactive authentication.

What I have tried: Make both of the users have the same password, both are in the same group and that group is in the sshd_config file. The only difference between the accounts are the name which are both 4 characters long. Any ideas on what I am missing? I have also reset both account passwords just in case I missed something. I'm assuming somewhere a permission issue is causing this but not sure where to start looking.

Edit:

Errors message from /var/log/secure file:

error: PAM: Authentication failure for from

pam_unix(sshd:auth): conversation failed

pam_unix(sshd:auth): auth could not identify password for [user]

error: ssh_msg_send: write

0

First of all - always check logs. The /var/log/secure will log every attempt to login with ssh by default. You can open it with tail -f /var/log/secure and try to login as a user in a separate window.

Next, make sure the user has a valid shell. You can check it with grep username /etc/passwd. To change shell to bash use chsh username -s /bin/bash.

Make sure the user has a home directory. His home directory is also listed in /etc/passwd, and you can check it with su - username and then cd ~. If his home folder does not exist, you should create it, but make sure to set the correct ownership. Though lack of home directory should not prevent this user from loging in.

Check your sshd_config if your user listed in DenyUsers. If it is not, try to add it to AllowUsers. If your sshd_config does not have it, the syntax is:

AllowUsers username
  • Added messages from the secure log (thanks). The shell is correct and the user does a home directory. We have a group sshusers that is stated as AllowGroup sshusers. I have also tried just putting the individual users and it didn't work. – TheAirborneranger Jun 19 at 14:58
  • @TheAirborneranger I updated the answer, check the DenyUsers / AllowUsers – deimos Jun 19 at 15:01
  • Yea we have AllowUsers and didn't work. It looks like a Pam issue from what the logs are saying. – TheAirborneranger Jun 19 at 15:03
  • @TheAirborneranger do you have any custom Pam modules? And... Did you try turning it off and on again?.. – deimos Jun 19 at 15:09
  • Also does it only affect password auth? Are you able to login with a key? – deimos Jun 19 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.