1

I installed Pop!_OS on my surface laptop (From windows to Linux). It is the only OS on my system. As the keyboard doesn't work as it should I tried to do the steps from this tutorial. After I completed these steps I did a reboot. After that the system won't boot anymore. I just have a black screen with a non blinking underscore in the top left corner.

After that I wanted to do a fresh install -> plugged in the usb stick from the installation before and reboot the system. But this time the system didn't load the installation, instead it loads grub.

For grub I also looked into several tutorials to get the usb stick booted but I couldn't get it to work. So now I need specific help as I don't know what happened and how to fix it.

I want to do a complete and clean install from the usb stick as I did earlier this day. These are the partitions I have.

(memdisk) (hd0) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (cd0) (cd0,msdos2)

I think (hd0,gpt2) is the current installation and (cd0,msdos2) is the usb stick. But I'am not 100% sure.

  • It looks that the partition system didn't change with your installation, all gpt partitions are the ones created by the Windows installer. Maybe would be best if you first create the partitions you like, and then install the OS. You can use gparted.org (availbale as a live system to flash in a USB). – guillermo chamorro Jun 19 at 13:49
0

In order to make a fresh install, you need to boot from the USB stick. For that, you need to force it from BIOS, as if you are loading GRUB, the BIOS is already booting from hard drive instead of USB-stick.

  • Thanks for your reply. I disabled all boot options in the BIOS except "boot from usb" so I don't think that it boots from hdd. Second thing is that if I don't plugin in the bootable usb it doesn't load grub. The system only loads grub when the bootable usb is plugged in. – emha Jun 19 at 13:24
  • Then I'd bet the USB is not correctly set to install the OS. Which program did you use to flash it? Rufus? – EUS Jun 19 at 13:37
  • I used balena.io/etcher for that. This worked fine on the first install. – emha Jun 19 at 13:41
  • @emha Try with a different installer, YUMI, Rufus for example. – guillermo chamorro Jun 19 at 13:45
  • Will give it a try and report later, thanks for your help! – emha Jun 19 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.