1

after some conda packages installation, I restarted the computer and Fedora got stuck at starting. I booted in maintenance mode, tried dnf update just to get some clue, and got an error in /usr/lib/python3.6

ModuleNotFoundError: No Module named 'librepo'

I get I messed up my python 3.6 somehow, but how is the best way to proceed to clean it up? and why the system is not starting normally?

Thanks

Edit:

Thanks for the answers. Unfortunately they reached me too late. I needed to work with my computer so I reinstalled the whole system. Other ideas didn't occur to me because it was evident that something was very wrong with the package manager systems (both dnf and yum were compromised).

Re: https://stackoverflow.com/questions/48291272/no-module-librepo-after-installing-pytorch-on-fedora27/48726460#48726460 I do agree with: "Fedora is not completely compatible with conda." I don't know about "Fedora bug reports get closed as duplicate with links to obviously unrelated reports." because I didn't try filing a bug report.

Thanks again

0

Try first upgrading dnf, rpm and friends, sometimes it gets stuck in there.

Try erasing the offending package (if it's Python, tread carefully... it is used all over the place, and can erase a lot of other things).

If you have the package downloaded already, perhaps going to a raw "rpm -Uhv --force package.rpm" (essentially, install or reinstall) fixes the problem.

  • Thanks. I had tried upgrading dnf and yum but both were compromised. Didn't try removing offending python packages because, as you said, I thought that they would remove lots of other things and eventually make the situation even worse. – Margherita Di Leo Jun 24 at 8:20
-1

Welcome to SE.

Have a look here. I am not sure if this will work for f30(you missed your Fedora version), but the problem seems to be similar.

  • Thanks. Indeed, I think it's a similar issue. Unfortunately your answer didn't reach me earlier, I had already formatted. Thanks anyhow. – Margherita Di Leo Jun 24 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.