0

I do understand this subject gets answered a lot. I have a debian laptop that 1366x768 60.02. Now the TV fits everything if I use the same res. I would like for the tv to run at 1920x1080 30.00* (60 causes distortion), but I am losing several pixels on all sides using that size. My gpu is intel and I have no overscan option. My TV is cheap and has no overscan controls that I can find and yet it obvious is doing it. This means xrandr overscan options do not work.

xrandr --output HDMI-1 --fb 1920x1080
xrandr: specified screen 1920x1080 not large enough for output HDMI-1 (1920x1080+1542+0)

Creates a thin viewing area and can only be reset by,

xrandr --output HDMI-1 --scale 1x1

which sets me back to all edges being lost.

Now I find panning may be a possibly but I can little examples and explanations help me understanding how it works enough to give the code to get me what I want. Has what happens a lot in linux coding depends upon dates that it was used and graphics cards being used. As a 2019 edition xorg is now just about gone and is now replaced by wayland which can influence how things work. Is there anyway I can use 1920 instead of 1366

1
  • This has been asked before; and to my knowledge there is no solution. If this was X, your best bet is to tell your Window Manager to only place windows inside a smaller area, but I have no idea how that would work on Wayland. Also note that even though your TV may accept 1920x1080, many cheap TVs actually have a smaller physical resolution, so it may downscale that anyway. Check the manual of your TV. – dirkt Jun 24 '19 at 9:59
1

As far as I understand, the xrandr --fb option sets the framebuffer size, or in other words, the total desktop size to which all your display devices should fit into. You can think of it as the master coordinate grid that must cover all your displays (unless you're trying to have multiple copies of the same view for e.g. presentation purposes).

For example, if you're using the laptop screen and the TV side-by-side (as would be suggested by the error message ...for output HDMI-1 (1920x1080+1542+0)), then your framebuffer size would need to be the sum of the widths of both your screens and and the height of your largest screen, i.e. (1366 + 1920) x 1080 = 3286x1080.

Usually this would be set automatically to match the resolutions and arrangement of your displays, so the fact that you're forcing it might explain the "thin viewing area" you're seeing.

Actually, the +1542+0 part in (1920x1080+1542+0) indicates you're offsetting the location of the left edge of your TV display from the right edge of your laptop screen, so your current layout described in terms of the master coordinate grid would be something like:

  • X coordinate range 0..1365: your laptop display
  • X coordinate range 1366..1541: area not covered by any display at all(!)
  • X coordinate range 1542..3462: your TV display.

  • Y coordinate range 0..767: visible on both displays

  • Y coordinate range 768..1079: visible on TV only

So I think whatever you're attempting to do to overcome the TV's overscan is actually having the opposite effect and causing some of the desktop to be left outside of any display at all.

Switching the display mode of the TV would be achieved using the --mode option instead, like this:

xrandr --output HDMI-1 --mode 1920x1080 --rate 30

Unlike --fb, --mode is listed as one of the per-output options on the xrandr(1) man page.

But first, you might want to check which modes are supported by your TV, by entering just xrandr with no parameters and reading the output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.