1

My computer has two drives, a boot drive and a storage drive and I'm running Ubuntu 18.04. However, for some reason my storage drive is unusable.

$ ls
'$RECYCLE.BIN'   _SMSTaskSequence  'System Volume Information'
$ mkdir new_folder
mkdir: cannot create directory ‘new_folder’: Read-only file system
$ sudo mkdir new
[sudo] password for ncw135: 
mkdir: cannot create directory ‘new’: Read-only file system

I then ran

$ sudo mount -o remount,rw,uid=1000,gid=1000 /media/ncw135/DATA/

base on this question which has changed the error message to

$ cd /media/ncw135/DATA/  # i.e. the storage drive
/media/ncw135/DATA$ mkdir new
$ mkdir: cannot create directory ‘new’: No such file or directory
/media/ncw135/DATA$ 

Any ideas on how to fix this problem? Thanks

Edit - Progress

I tried to mount the drive somewhere else and got the following:

$ sudo mount /dev/sda2 ~/storage/
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
  • 2
    What file system(s) are you using for each of your drives? – Lucas Ramage Jun 18 '19 at 12:23
  • I'm not sure, but I haven't changed anything - so whatever the default for ubuntu 18.04 is I guess. – CiaranWelsh Jun 18 '19 at 12:25
  • 1
    Turns out this drive was partitioned for windows. I reformatted the disk, remounted and the problem is solved. Thanks for pointing me in the right direction – CiaranWelsh Jun 18 '19 at 12:35
  • 1
    Awesome! Glad to have helped. – Lucas Ramage Jun 18 '19 at 13:07
2

The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Falling back to read-only mount because the NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting.)

This indicates the NTFS filesystem was used in a Windows system with hibernation, or in a Windows 8 or 10 system with the Fast Startup feature enabled (in Windows 10, Fast Startup is usually enabled by default).

If you no longer have the Windows installation that wrote the metadata cache, and you can take the risk of losing the cached metadata (should be minimal with Fast Startup, all bets are off with hibernation) and use the remove_hiberfile mount option of the ntfs-3g filesystem driver:

sudo mount -t ntfs-3g -o remove_hiberfile /dev/sdaX /your/desired/location

After mounting the filesystem once like this, you can mount it normally the next time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.