0

Presently I am getting the error:

Application built with libpng-1.6.16 but running with 1.5.13

Upon getting this error I tried reinstalling* libpng1.6.16 from source per this guide, which seems to be recognized by the system..

[root@raven home]# libpng-config --version
1.6.16

But I got the same error. So next I tried re-building Mapnik making sure to point the .configure step at the libpng install "prefix", like this..

[root@raven home]# libpng-config --prefix
/usr

with the Mapnik .configure instruction looking like..

./configure BOOST_LIBS=/opt/boost/lib BOOST_INCLUDES=/opt/boost/includes PNG_INCLUDES=/usr PNG_LIBS=/usr

But when I clear my tiles, tail -f the Apache error log, and request a tile from my problem layer, I still get the same error:

Application built with libpng-1.6.16 but running with 1.5.13

Even though all indicators suggest I built Mapnik against libpng 1.6.16 in addition to running libpng 1.6.16.

So clearly there is something I am not understanding about this error.

The Question: If I am running a specific library version, and if I built an application against that same library version, why am I getting an error that my running/build versions are out of sync?

Server is CentOS 7. The Application is Mapnik 3.0.22. For the most part, Mapnik is working, but it only throws errors when it needs to read any .PNG assets for inclusion in tile rendering. Curiously, it renders .PNG just fine.


*To clarify: When I say I "reinstalled', I should specify that I didn't uninstall libpng first. I just followed those instructions to install it from source, to which, libpng-config --version suggests the proper version is in place. But maybe some stale parts are lingering around. Or maybe I was supposed to move the includes files somewhere?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.