4

I just got a new (to me) 27" monitor as an upgrade to my old 22" Acer (with the hope to eventually do dual monitors). The only way I can get it to work is to boot the PC (Motherboard: ASRock B450 Pro 4) while connected to the old monitor, and then taking the (HDMI to DVI) cord out of the old monitor and plugging it into the new one. Then the new monitor works, but it is stuck at the resolution of the smaller monitor. If I ever restart the computer, the new monitor will never get a signal from the computer and will just show a "No Signal" message.

I've tried using other cables (pure HDMI, old school D-SUB) with both monitors, together and separately. The only time my computer recognizes a monitor at all is when ONLY the old monitor is connected and ONLY the way it was when I first built my computer: with the HDMI-to-DVI adapter cable.

The motherboard has three video ports: VGA (DB-15), DisplayPort, and HDMI (4k capable).

Here's all the info I've managed to gather:

Graphics: I'm using the integrated Radeon RX Vega 11 Graphics from my Quad-CoreAMD Ryzen 5.

Monitors: old (aka The One That Works) is 22" Acer G236HL, and new is 27" AOC E2752VH (ca. 2014, since discontinued, out of warranty)

xrandr

scott@scott-desktop:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00* 

inxi

scott@scott-desktop:~$ inxi -Fxz
System:    Host: scott-desktop Kernel: 4.9.0-8-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: ASRock model: B450 Pro4 UEFI: American Megatrends v: P1.30 date: 07/04/2018
CPU:       Quad core AMD Ryzen 5 2400G with Radeon Vega Graphics (-HT-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28744
           clock speeds: max: 3600 MHz 1: 2300 MHz 2: 1600 MHz 3: 1600 MHz 4: 1600 MHz 5: 2300 MHz
           6: 1600 MHz 7: 1600 MHz 8: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 15dd bus-ID: 38:00.0
           Display Server: X.Org 1.19.2 drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
           Resolution: 1920x1080@77.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 15e3 driver: snd_hda_intel bus-ID: 38:00.6
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15de
           driver: snd_hda_intel bus-ID: 38:00.1
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 25:00.0
           IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 480.1GB (5.7% used)
           ID-1: /dev/sda model: ADATA_SU650 size: 480.1GB temp: 42C
Partition: ID-1: / size: 432G used: 19G (5%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 7.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 239 Uptime: 18 min Memory: 1356.3/6970.5MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0 Client: Shell (bash 4.4.121) inxi: 2.3.5 

Happy to gather any other info or try anything that might be helpful, but I've never had a monitor not "just work" so I'm at a loss as to how to proceed from here.

Thanks for your help!

  • 1
    Thanks @K7AAY, I've added that information. – Scott Jun 18 at 0:21
  • @Scott, have you tried ASRock support at event.asrock.com/tsd.asp ? They've been known to be helpful. And, have you tried a DisplayPort-HDMI cable to the AOC monitor? – K7AAY Jun 18 at 17:37
  • 1
    Alas, I don't have a displayport-HDMI cable. Is there reason to hope it would behave differently? Because that'd certainly be reason enough to spend the few bucks to order one. I haven't reached out to ASRock support, but I will try that as well. – Scott Jun 19 at 12:51
  • Paraphrasing Churchill, "Talk talk is cheaper than spend spend." Try ASRock support first. – K7AAY Jun 19 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.