0

Tried to install firefox, at first the dependent packages were installed correctly. But at the end I got the following errors:

$nix-env -i firefox-67.0.1
...
post-installation fixup
Moving /nix/store/qx4w4841grng03q819hmaj315j7a9w6r-compiler-rt-7.1.0/include to /nix/store/a0dxd8aiqvpfxwlpv44d0xbpkmcxcq0g-compiler-rt-7.1.0-dev/include
Removing empty /nix/store/qx4w4841grng03q819hmaj315j7a9w6r-compiler-rt-7.1.0/ and (possibly) its parents
strip is /nix/store/ah81jgj71sr7nmvy4pc6x89pgpr6ygvk-binutils-2.31.1/bin/strip
shrinking RPATHs of ELF executables and libraries in /nix/store/a0dxd8aiqvpfxwlpv44d0xbpkmcxcq0g-compiler-rt-7.1.0-dev
strip is /nix/store/ah81jgj71sr7nmvy4pc6x89pgpr6ygvk-binutils-2.31.1/bin/strip
patching script interpreter paths in /nix/store/a0dxd8aiqvpfxwlpv44d0xbpkmcxcq0g-compiler-rt-7.1.0-dev
checking for references to /build/ in /nix/store/a0dxd8aiqvpfxwlpv44d0xbpkmcxcq0g-compiler-rt-7.1.0-dev...
builder for '/nix/store/75sxcn605fsqr3jgbf70chn8550rvk4j-compiler-rt-7.1.0.drv' failed to produce output path '/nix/store/qx4w4841grng03q819hmaj315j7a9w6r-compiler-rt-7.1.0'
cannot build derivation '/nix/store/d6rh69f4gik90sm24p422gf3zpws6svb-clang-wrapper-7.1.0.drv': 1 dependencies couldn't be built
copying path '/nix/store/p7dyx7mwj4llimn0ydm6dkw910j81sgz-gtk+-2.24.32-dev' from 'https://cache.nixos.org'...
cannot build derivation '/nix/store/ihd6b877m513q4aq9q0gddxgl7b6lw2b-firefox-unwrapped-67.0.1.drv': 1 dependencies couldn't be built
copying path '/nix/store/zwrn3cwjl7gs7kaj872pyzzrd0j98kbr-gtk+3-3.24.8-dev' from 'https://cache.nixos.org'...
cannot build derivation '/nix/store/r85ddzbfic2jvypaskj6brbd51fy64h1-firefox-67.0.1.drv': 1 dependencies couldn't be built
error: build of '/nix/store/r85ddzbfic2jvypaskj6brbd51fy64h1-firefox-67.0.1.drv' failed
2

The problem isn't in firefox build itself but in llvmPackages.compiler-rt. I think it's better to use the issue tracker for this kind of problems: https://github.com/nixos/nixpkgs/issues

... but let me try to help here anyway. The whole firefox builds show OK on the build farm in the past few weeks (master, 19.03), so: (1) you might try to figure out why the binaries from Hydra aren't used (in case that's not intentional by you) – I can see the path isn't in there so you may have unusual/unexpected source version or override; (2) you may try to find why it fails locally... my first guess would be that you have sandboxing disabled and that exposes some impurity in the build.

  • "you might try to figure out why the binaries from Hydra aren't used" - how to do it? – user4035 Jun 18 at 8:51
  • I would start by checking if your nixpkgs configuration is what you expect. In particular the expressions that get evaluated (nix-channel usually). – Vladimír Čunát Jun 18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.