5

Each time I login to Fedora 17, no GUI, just a console, I notice this error:

Cannot open font file True

I have followed some tutorial on web to fix this problem, but still cannot. Here some steps that I have done:

  1. Edit /etc/default/grub

    vi /etc/default/grub. After that, change SYSFONT=True to SYSFONT=atarcyrheb-sun16

  2. Edit /etc/sysconfig/i18n. Same, change SYSFONT=True to SYSFONT=atarcyrheb-sun16

  3. Rebuild Grub2 with the command grub2-mkconfig -o /boot/grub2/grub.cfg

In my boot folder, I don't have a grub2 directory. I must create it first with mkdir /boot/grub2

But no matter how I try, I still meet this frustrating error. When I boot to recovering mode, I see a failed operation : failed to mount /media/sda8. Does it matter to my error?

  • As I see the same "missing font" (is True a flag to use some default?), the mounting problem seems to be unrelated. See Redhat/Fedora Bug 799401 – fheub Oct 24 '12 at 6:51
1

I fixed it by setting the font with:

SYSFONT=latarcyrheb-sun16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.