1

I am trying to install vs code on CernVm but it shows the following errors:

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package code.x86_64 0:1.35.1-1560350390.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: code-1.35.1-1560350390.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: code-1.35.1-1560350390.el7.x86_64
--> Processing Dependency: libsecret-1.so.0()(64bit) for package: code-1.35.1-1560350390.el7.x86_64
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: code-1.35.1-1560350390.el7.x86_64
--> Finished Dependency Resolution
Error: Package: code-1.35.1-1560350390.el7.x86_64 (code)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: code-1.35.1-1560350390.el7.x86_64 (code)
           Requires: libgtk-3.so.0()(64bit)
Error: Package: code-1.35.1-1560350390.el7.x86_64 (code)
           Requires: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
Error: Package: code-1.35.1-1560350390.el7.x86_64 (code)
           Requires: libsecret-1.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


I have gone through various websites trying to figure out how to install libstdc++.so.6 and am thoroughly confused now. I have no idea if the compiled to be download as a .rpm file is even available for CernVM or for Scientific Linux.
Somewhere I read that vs code may be installed using dnf. So I added the EPEL repo-to no avail. I can't seem to get dnf installed no matter what.

I have already tried yum update, yum upgrade, yum --obsoletes update etc commands and tried cleaning cache.....and what not--they have no effect on the error messages.

Please help...remember that the main goal is to install VS Code(a solution that works for any reasonably old version of vs code is fine but that one that works for the latest version would be nice).

Env:

$  cat /etc/issue
Welcome to CERN Virtual Machine, version 3.7.2.8
  based on Scientific Linux release 6.9 (Carbon)
  Kernel 4.1.44-30.cernvm.x86_64 on an x86_64

running on VirtualBox Version 5.2.18 on Ubuntu 18

  • 1
    Also consider monodevelop. It is both better and worse that Visual Studio professional (is that the name of the top/best version). – ctrl-alt-delor Jun 16 at 19:45
  • @ctrl-alt-delor oh ..you misunderstood..the latest version of visual studio code itself...and it's the code editor not vs pro ide. I'll look up monodeveleop but I need vs code's installation now. – lineage Jun 16 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.