0

I have a (relatively) old USB sound card, EMU-0404. It's official drivers (for Win/Mac) were not updated for years (last Windows official support is for Win 7, with 64 bit drivers in beta release)

Today I (accidentally) discovered that it is identified in Ubuntu 18.04 in the audio settings - as 'Emu-0404' with all the analog and digital in/out. That's great, but the sound quality is bad, there are noticeable digital artifacts.

Is there a way to make it work properly?

  • 3
    There's probably a way to make it work properly, but it's impossible to do with the information you supplied. First step is to look at the alsamixer settings and adjust mixers to avoid clipping. If that doesn't help, the second step is to describe the "noticable digital artifacts" and narrow down their source. – dirkt Jun 16 at 9:47
  • @dirkt thanks, I will edit the post with more info – Itamar Katz Jun 17 at 6:47
  • Well the levels in alsamixer were ok, but I saw a clock rate option and when I changed it from 0 to 20 (I guess these are just placeholders for the sample rate) the sound is perfectly ok. Thanks! Btw, if the sound card is identified and works, does it mean there's a support for the specific hardware? or it's just a generic driver that does the job? – Itamar Katz Jun 20 at 5:04
  • 1
    Voted for reopen so you can add your comment as an answer. – dirkt Jun 20 at 6:55
  • There are both generic drivers ("USB sound") and specific drivers. The way to find out it is to use e.g. dmesg or lsmod and find out which driver got loaded. And "support" can also mean "someone at some time wrote some code for it, but it's open source, so you can fix any problems yourself if you like" (which is still better than "we are a company and are not telling anyone how our stuff works; if you bought it and it doesn't work, tough luck"). – dirkt Jun 20 at 6:59
1

First step is to look at the alsamixer settings and adjust mixers to avoid clipping. If that doesn't help, the second step is to describe the "noticable digital artifacts" and narrow down their source.

Poster reports:

Well the levels in alsamixer were ok, but I saw a clock rate option and when I changed it from 0 to 20 (I guess these are just placeholders for the sample rate) the sound is perfectly ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.