1

I did a clean install of KDE Neon this week and I noticed Firefox is not really set as default. When I go in system settings I see it is set. When I open a .html file or click on a link, it opens Firefox.

enter image description here

But when I go in Firefox preferences, it is not detected as default:

enter image description here

Additionally, I cannot open my Firefox Bookmark with Krunner (which is very annoying), but I think the two problems are related.

How could I fix this issue?

1

It's something with an environment variable:

I have the same problem and it seems an issue with KDE itself. I've found that the whole problem is related to the following environment variable:

GTK_USE_PORTAL

To fix:

As we all known, KDE works on QT and it's probable something with GTK on Firefox. To fix the issue, one must edit the following file:

/usr/share/applications/firefox.desktop

And on the first Exec line within the file, you have to add env --unset=GTK_USE_PORTAL, in order to execute Firefox in a proper way. So the line on the file have to be as follows:

Exec=env --unset=GTK_USE_PORTAL /usr/lib/firefox/firefox %u

After that you must reboot and then, open your firefox settings and try to set it as your default browser.

1
  • Thanks, did work for me - though the change had to be made under /home/usr/.local/share/applications/firefox.desktop – Tom May 9 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.