7

When I press the "é" key multiple times on my keyboard, here is what tmux print (notice the spaces) :

arcanis@~ > é é é é é é é é é é é é é

It also broke emacs when the file contains utf8 characters.

My locale is :

arcanis@~ > locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

How can I fix this ?

3
  • Is tmux itself started in a UTF-8 locale? – Gilles 'SO- stop being evil' Oct 21 '12 at 23:55
  • @Gilles Yes, the original locales are fr_FR.UTF-8 (except LC_ALL which is empty), and tmux is started using -u. – Nison Maël Oct 22 '12 at 0:31
  • 1
    Try using the tmux command utf8 on and see if that helps. – Keith Oct 22 '12 at 2:06
2

.tmux.conf

set -g utf8 on

Fixed the exact same issue for me.

1
  • 2
    Note that this option is the default in Tmux since around 2016, and is no longer a valid option. – dotancohen Jul 12 '20 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.