1

I recently bought a HP 15-da0206ng laptop and since my goal was to finally switch from Windows to Linux I installed the Linux distribution Pop!_OS 18.04 LTS which is built on Ubuntu 18.04 LTS.

After I installed the OS, I encountered a problem: No WIFI Adapter was detected. The WIFI Adapter in the HP 15-da0206ng is a Realtek RTL8821CE 802.11b/g/n/ac, according to HP. I quickly found a solution for this:

https://askubuntu.com/questions/1071299/how-to-install-wi-fi-driver-for-realtek-rtl8821ce-on-ubuntu-18-04

I disabled secure boot in BIOS, connected my Laptop via cable updated and upgraded and installed the driver and my WIFI Adapter was detected and worked. However, my download speed via wifi is very slow. The terminal and the browsers (Firefox and Chrome) download everything with a speed of around 85 kb/s. According to this site (it is a German site):

http://www.speedmeter.de/

my download speed is at 0.6-0.7 mbit/s. My upload speed is at 5 mbit/s which I consider normal. I did the same speed check with my Samsung phone and it reaches a download speed of 102 mbit/s and an upload speed of 5 mbit/s. Something is clearly wrong with the download speed of my Notebook.

After researching this problem I found this thread: https://askubuntu.com/questions/1148030/slow-wifi-connection-ubuntu-18-04/1148065?r=SearchResults#1148065

but switching antennas resulted in no difference. Selecting a specific antenna explicitly seems to be a working solution if your wifi signal is not strong, as it is explained here: https://askubuntu.com/questions/1058379/wifi-signal-is-weak-in-ubuntu-18-04-with-rtl8723be

In my case I would say that the signal strength is not a problem. As you can see in the results of running nmcli dev wifi list

IN-USE  SSID                            MODE   CHAN  RATE        SIGNAL  BARS  SECURITY  
 *       Burt-Reynolds                   Infra  1     405 Mbit/s  82      ▂▄▆█  WPA2 

I also turned of power saving for the wifi adapter as described at the bottom of this readme: https://github.com/tomaspinho/rtl8821ce/blob/master/README.md but it did not make any difference as well.

I upgraded the kernel from 4.18 to 4.19 but there was no change. I tried to install Ubuntu (instead of Pop!_OS) 18.04 but here I did not manage to install the rtl8821ce drivers at all. Currently I am running Pop!_OS 19.04 where I can install the drivers again but the download speed is still painful slow.

Furthermore I went through this troubleshooting: https://support.system76.com/articles/wireless/

which means I tried to change the router configuration, I disabled IPv6, I enabled Antenna Aggregation, I tried to disable the N mode in /etc/modprobe.d/iwlwifi.conf and I disabled bluetooth coexistence.

I am not quite sure what to try anymore and my next steps will be to buy a usb wifi adapter or, the worst case, install Windows again. It seems that most questions related to the rtl8821ce are about getting it not working at all. In my case it works but very slowly. I am not sure if I am missing something obvious and that is why I decided to post this problem here.

Here is some additional hardware information:

Intel® Core™ i5-8250U
DDR4-2400 SDRAM, 16 GB      
256 GB PCIe® NVMe™ M.2 SSD
Intel® UHD Graphics 620

Thanks in advance.

  • Try to use aria2c as aria2c -x16 -s16 -c "link here". – Biswapriyo Jun 16 '19 at 13:16
  • Hi, I tried to download something with aria2c but it does not make any difference. The download runs with 80 kb/s – Jannik Günther Jun 16 '19 at 17:10
0

If anyone has this issue with the specific driver, it's due to multiple installation of same driver.

To confirm dkms status .

if it list multiple driver for same wifi card, need to remove all other drivers except required one. Drive removal script is included in the driver repo in github.

sudo ./dkms-remove.sh

final configuration should be somewhat similar to: dkms status

rtl8821ce, 5.5.2.1, 5.4.0-7634-generic, x86_64: installed
system76, 1.0.9~1597073326~20.04~5b01933, 5.4.0-7634-generic, x86_64: installed
system76_acpi, 1.0.1~1594068101~20.04~54ac52e, 5.4.0-7625-generic, x86_64: installed
system76_acpi, 1.0.1~1594068101~20.04~54ac52e, 5.4.0-7634-generic, x86_64: installed
system76-io, 1.0.1~1559663713~20.04~ea5f61a, 5.4.0-7625-generic, x86_64: installed
system76-io, 1.0.1~1559663713~20.04~ea5f61a, 5.4.0-7634-generic, x86_64: installed
  • Thanks for your suggestion. I checked for multiple installation of the same driver but I only have one. The issue still exists, nevertheless. I have the exact driver version of rtl8821ce you listed in your post. – Jannik Günther Aug 14 '20 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.